Last Comment Bug 332872 - get rid of unnecessary switch debug console warning
: get rid of unnecessary switch debug console warning
Status: RESOLVED FIXED
: fixed1.8.0.5, fixed1.8.1
Product: Core
Classification: Components
Component: XForms (show other bugs)
: Trunk
: x86 All
: -- minor (vote)
: ---
Assigned To: aaronr
: Stephen Pride
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 12:50 PDT by aaronr
Modified: 2006-06-06 07:02 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.56 KB, patch)
2006-04-05 12:54 PDT, aaronr
doronr: review+
bugs: review+
Details | Diff | Review
testcase (1.26 KB, application/xhtml+xml)
2006-04-05 12:56 PDT, aaronr
no flags Details
fixed testcase (1.27 KB, application/xhtml+xml)
2006-04-05 12:58 PDT, aaronr
no flags Details

Description aaronr 2006-04-05 12:50:23 PDT
I noticed a debug console warning when loading a switch.  It is generated by nsXFormsCaseElement::SetSelected failing due to the fact that when it tries to QI the case element to a nsIXFormsCaseElementUI and it can't because XBL hasn't attached yet.  It is ok that it fails, but the debug console error is annoying me :=)
Comment 1 aaronr 2006-04-05 12:54:01 PDT
Created attachment 217328 [details] [diff] [review]
patch
Comment 2 aaronr 2006-04-05 12:56:28 PDT
Created attachment 217329 [details]
testcase
Comment 3 aaronr 2006-04-05 12:58:55 PDT
Created attachment 217330 [details]
fixed testcase

first testcase had missing </h2>...ugh!
Comment 4 aaronr 2006-04-13 13:24:07 PDT
checked into trunk on 2006/04/11

Note You need to log in before you can comment on or make changes to this bug.