If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

xml styled tags not highligted in source if mimetype is text/html

RESOLVED WORKSFORME

Status

()

Core
HTML: Parser
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Mitch 74, Assigned: mrbkap)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); fr; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); fr; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

When creating an html page, the use of xml styled tags is an error if mimetype is text/html. However, said error isn't highlighted in the page source, while actual page content reflects the error.

Reproducible: Always

Steps to Reproduce:
1.copy the sample source code to a .php page
2.view it a first time
3.in the source, comment out the line $mime = "application/xhtml+xml"; (add // at the beginning)
4.view it a second time, text colors are different.
5.view page source.

Actual Results:  
the page source is that of 'correct' code

Expected Results:  
<a id="test2" /> should be highlighted in the page source

this stems from bug 332580
(Reporter)

Comment 1

12 years ago
Created attachment 217387 [details]
sample case: php file (allows easy mime-type change) with demo code
(Reporter)

Updated

12 years ago
Attachment #217387 - Attachment mime type: application/octet-stream → text/text
(Reporter)

Updated

12 years ago
Attachment #217387 - Attachment mime type: text/text → text/html
(Reporter)

Updated

12 years ago
Attachment #217387 - Attachment mime type: text/html → application/octet-stream
(Reporter)

Comment 2

12 years ago
Created attachment 217397 [details]
sample code: directly visible, the 'erroneous' version

this should display colors all wrong; but the faulty tag (<a id="test2" /> isn't highlighted in source
(Reporter)

Comment 3

12 years ago
Created attachment 217398 [details]
sample code: the 'correct' version

this should display the correct page formatting, with the correct MIME type.
(Reporter)

Comment 4

12 years ago
I've added 2 further attachments, they allow the differences to be more handily visible between the 2 pages. When displayed however, the source code shows no difference (which is normal) but doesn't highlight 'incorrect' xml code in the text/html version (which is not normal).

It is strange though, that the style applied to the anchor tag (which should affect font colour but not background), when applied to the following paragraph, modifies colour AND background (the following paragraph is still treated as a paragraph, but the anchor style is transformed into paragraph style).

Updated

12 years ago
Keywords: testcase
On my build the "/" part in attachment 217397 [details] is shown in red, which is us highlighting the invalid code. Does that not happen for you?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

12 years ago
I'm using Bon Echo a1/Win32 as my most recent build, and it doesn't highlight it. What build are you using?
(Reporter)

Comment 7

12 years ago
Fixed as of Deer Park 1.6a1 - 2006/04/06 nightly
You need to log in before you can comment on or make changes to this bug.