Detach attachment removes mail from server

RESOLVED WORKSFORME

Status

MailNews Core
Attachments
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: robert.boeck, Assigned: Bienvenu)

Tracking

1.0 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0 Mnenhy/0.7.3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0 Mnenhy/0.7.3.0

In the Server Settings of my POP3 mail accounts I have the following settings:
[x] Leave messages on server
 [x] Until I delete or move them from Inbox

When I detach an attachment, the related mail is removed from the POP3 server.


Reproducible: Always

Steps to Reproduce:
1. setup an POP3 mail account al follows:
   [x] Leave messages on server
    [x] Until I delete or move them from Inbox
3. receive mails with attachments
3. open a mail with an attachment
4 [review]. right click into attachments and chose "Detach All"
5. receive new mails from the POP3 server
Actual Results:  
The mail is removed from the POP3 server.

Expected Results:  
The mail should not be removed from the POP3 server, because it neither was deleted nor it was moved from the inbox.
(Assignee)

Updated

12 years ago
Component: MailNews: Offline → MailNews: Attachments
Product: Mozilla Application Suite → Core
Version: unspecified → Trunk
(Assignee)

Comment 1

12 years ago
I suspect this happens because internally, removing the attachment involves making a new message w/o the attachment and deleting the original. If so, this might be tricky to fix.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

12 years ago
I believe there's another bug concerning to this behaviour. I've sorted the mails by "Order Received". If I detach an attachment from a mail, the related mail is sorted as the latest mail that was received, even if the mail was an old one.
(Assignee)

Comment 3

12 years ago
that's just the way it works, since order received sorts by order in the mailbox, and detaching involves rewriting the message at the end of the mailbox.
(Reporter)

Comment 4

12 years ago
This is quite confusing. If the order is by received, I expect the order by the date really received. If the message is rewritten internally, I don't be interested about the date rewritten. Althouh I'm a programmer, I'm behaving like an user in this case.
(Reporter)

Comment 5

10 years ago
POP3 mails aren't deleted after detaching attachments anymore.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Version: Trunk → 1.0 Branch
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.