Open In Tabs overwrites currently open in tabs

RESOLVED DUPLICATE of bug 216346

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 216346
12 years ago
12 years ago

People

(Reporter: Julian D. A. Wiseman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Start with a bookmark folder containing several bookmarks, and a browsing window with several tabs open. Choosing the menu item 'Open In Tabs' from the bottom of that folder's pop-out menu then causes the sites to be opened in the tabs that are already open (adding more tabs if there are fewer tabs open than items in the folder). Surely what should happen is that the numerous bookmarks are opened in new tabs, not overwriting the already-used tabs. (I don't mind overwriting the frontmost tab, but overwriting them all seems counter-intuitive.) 

Reproducible: Always

Steps to Reproduce:
You can fix it by toggling the hidden pref browser.tabs.loadFolderAndReplace to false in about:config, but apparently the closest to not clobbering by default we're going to get is bug 175124.

*** This bug has been marked as a duplicate of 216346 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.