Minimum font size dropdown list is not editable and contains bad entries

RESOLVED INVALID

Status

()

Firefox
Preferences
--
enhancement
RESOLVED INVALID
12 years ago
8 years ago

People

(Reporter: Jonathan Haas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060331 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060331 Firefox/1.6a1

Goto Options->Content->Fonts & Colors->Advanced...

There is a dropdown list where you can set the minimum font-size. Unfortunately there are only a few entries you can select from and you can not enter your own values.

Reproducible: Always

Steps to Reproduce:
Dropdown minimum font-size list.


Actual Results:  
List contains a few entries but you can not define your own ones.

Expected Results:  
The box should be user-editable so that you can type your own values in.
Or: The list should contain more entries. The very big ones could be removed, but 4,5,6,7,8 should be in there.

The reason for this enhancement request is, that the minimum font-size is often used to make webpages with small font-sizes more readable. In the dropdown-list the maximum minimum font-size is 9 but 9 is quite big in my opinion. I don't want to make the fonts really big, but I want to make fonts with font-size:4px readable.

Additional in the dialog there is no infomation which unit the minimum-font-size has. Is it pt or px?
(Reporter)

Updated

12 years ago
Summary: Minimum font size dropdown list is not editabe and contains bad entries → Minimum font size dropdown list is not editable and contains bad entries
(Reporter)

Comment 1

12 years ago
PS: This does not apply to the minimum font-size only, all other font-size dropdowns have the same problems, too.

Comment 2

12 years ago
Reporter, you can manually enter your choice now via the urlbar. Enter there 'about:config', then 'font' in the search window to shorten the list so you can easily find the existing entries you want to change.

The sizes listed in the fonts & colors panel are all px. 9px is the generally recognized minimum size that provides enough pixels in a character box to fully define every character of the latin alphabet. Setting a minimum below 9px would therefore serve no useful purpose to any normal user. The big ones won't be removed, and in fact should include more so that users who select the largest sizes can easily make the default the same as the minimum. My own personal default is 28, while the largest available minimum is only 24.

Please look at bug 187093 and bug 253316 that are responsible for what we have now. Which sizes are missing that you would like to see there for variable and monospace?
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Setting a minimum below 9px would therefore serve no useful purpose to any 
> normal user. 

I disagree. 8px can be read without major problems if you use font smoothing like cleartype or xft. You do not have to differentiate a capital i from a l or a 1(one), you can get most letters out of context.

> Which sizes are missing that you would like to see there for variable and
> monospace?

Default font sizes may be OK, but I suggest adding at least 8 for the minimum font size dropdown. I don't like 9 because it makes the font of many websites bigger (and I like the default), but people may want to increase the font size on websites that are made by pseudo-artists that use 5px or 6px (or smaller) font sizes or in forum posts where people try to hide mini-messages in their posts.

PS: I'm an extension developer and I know how to edit about:config entries
(Reporter)

Comment 4

8 years ago
I'm just closing this old bug as I changed my mind. 9px should be ok as smallest font size.

I would still like, if these dropdown boxes (for example in the options window) could be edited by hand, too, so you could just enter "11 px" (or "6 px" if you really wanted) on your keyboard instead of having to select something from a large list. But that's another issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.