Closed Bug 333117 Opened 14 years ago Closed 14 years ago

Cannot use DEL key anymore to delete an item after inplace editing its title

Categories

(Calendar :: Internal Components, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: dbo, Assigned: michael.buettner)

References

Details

Attachments

(1 file)

Steps to reproduce:

1. create an event
2. double-click its title for inplace editing
3. modify + CR (item selection gets lost: IMO a bug, too)
4. select item and press DEL => does not work anymore until next lightning startup

note: DEL key deletion is ok when editing item title via event dialog.
confirmed on latest trunk version.
Assignee: nobody → michael.buettner
Status: NEW → ASSIGNED
*** Bug 343488 has been marked as a duplicate of this bug. ***
Component: Lightning → Base
QA Contact: lightning → base
Michael, any update on this bug?
I'm going to address this issue until end of this week.
Attached patch patch v1Splinter Review
stopEditing() in calendar-view-core.xml did not reset the state of the associated view correctly.
Attachment #234216 - Flags: second-review?(jminta)
Attachment #234216 - Flags: first-review?(thomas.benisch)
Comment on attachment 234216 [details] [diff] [review]
patch v1

r=tbe
Attachment #234216 - Flags: first-review?(thomas.benisch) → first-review+
Comment on attachment 234216 [details] [diff] [review]
patch v1

r=jminta
Attachment #234216 - Flags: second-review?(jminta) → second-review+
Whiteboard: [checkin needed]
patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Whiteboard: [checkin needed]
You need to log in before you can comment on or make changes to this bug.