Put more command buttons on places toolbar (especially "Move")

RESOLVED DUPLICATE of bug 365528

Status

()

Firefox
Bookmarks & History
P3
normal
RESOLVED DUPLICATE of bug 365528
12 years ago
9 years ago

People

(Reporter: Brett Wilson, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
Firefox 2 beta1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
The old bookmarks manager had nice big buttons for "Move" "Copy" "Rename". The new places window does not. We should consider whether we should add back any of these buttons. In explaining how to manage bookmarks to novice users, I have found it much easier to point to these nice big buttons. They advertise what you can do with the bookmarks to people that wouldn't necessarily think of looking in context menus or dragging.

Move and Copy might be overkill, but "Properties" might be good so people can edit the title, etc.
(Reporter)

Updated

12 years ago
Assignee: nobody → bugs

Comment 1

12 years ago
IMO we should give users the ability to configure the places toolbar including but not limited to large and small icons as well as being able to move them around where they best work for that user.

Bryan
Ok, but explain why? Is organizing your bookmarks something you will be doing often enough to care about trying to optimize the behaviour?

I'm of the absolutely opposite viewpoint here, we should only take on the code weight and complexity of toolbar configuration when there is a clear need for configuration.  We actually dropped it for Help in 1.5 based on that rationale, and there were very few complaints.  More buttons might be a win though, if they're useful/discoverable.
Priority: -- → P3
Target Milestone: --- → Firefox 2 beta1
(Reporter)

Updated

12 years ago
Summary: Put more command buttons on places toolbar → Put more command buttons on places toolbar (especially "Move")
(Reporter)

Comment 3

12 years ago
*** Bug 335062 has been marked as a duplicate of this bug. ***
The "Move" button work is tracked under bug 365538.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 365528
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.