HTML Message with <object> (embedded data) doesn't render

NEW
Unassigned

Status

MailNews Core
Backend
12 years ago
3 months ago

People

(Reporter: Mike Cowperthwaite, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
An HTML message containing an <object> which has a 'data' element pointing to a MIME part fails to render the object.  This is occurring on the trunk (pre-1.9) but not on the 1.8.1 branch -- I see the symptom with
  Seamonkey 1.5a-0329
  TB 3a1-0329
But not
  Seamonkey 1.0
  TB 2a1-0328

Test case follows
(Reporter)

Comment 1

12 years ago
Created attachment 217612 [details]
Sample message

Steps to Reproduce:
1) Integrate the attachment into message folders
2) Open the program
3) Select the message

Actual results:
<img> tag of data display as an image; <object> tag of same data does not

Expected results:
Both tags display the image.


With 1.8.1 branch or trunk, you can open also this file using   File|Open   rather than integrating into the mail folders; this will work fine to show how the branch does not exhibit the bug but the trunk does.  This same technique under Seamonkey 1.0/TB 1.5 does not display correctly (I think due to bug 206278).

Updated

10 years ago
QA Contact: backend
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 2

a year ago
Now displayed fine. Closing.

Thunderbird 52.0.1 (32-bit)
Windows 7 64-bit
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

3 months ago
(In reply to buovjaga from comment #2)
> Now displayed fine. Closing.
> 
> Thunderbird 52.0.1 (32-bit)
> Windows 7 64-bit

Tested with TB 52.6 (32-bit) Windows 10

Only one copy of the image displays.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

3 months ago
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.