Closed Bug 333220 Opened 15 years ago Closed 14 years ago

delete text in message reply under certain circumstances causes crash

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 304720

People

(Reporter: x-phile, Assigned: mscott)

Details

(Keywords: crash)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060228 SUSE/1.5.0.1-10.1 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060228 SUSE/1.5.0.1-10.1 Firefox/1.5.0.1

Replying to a message, I clicked at the top of the window to move my curser to the top, then hit enter twice to move the inline reply text down.  I inadvertently entered a character on a line.  I used my up arrow to go to that char, then hit the delete key, and thunderbird crashes

Reproducible: Always

Steps to Reproduce:
1.Reply to an e-mail
2.Click at top of text in compose window
3.hit enter
4.type a character
5.hit enter
6.up arrow once
7.hit delete key


Actual Results:  
Thunderbird exits completely

Expected Results:  
Deleting the character.

Using default thunderbird theme, and no talk-back window appeared after crash.
Version: unspecified → 1.5
I'm also getting this bug on a decent number of ( linux ) systems. I've got 5 x86 linux boxen, and 1 x86-64 box that this happens to. It's pretty damned annoying too. It seems to have slipped in between 1.0.x and 1.5.x.

Also, I don't have to follow the procedure outlined ( above ) to reproduce the bug. The 'backspace' and 'delete' keys are *dynamite* in Thunderbird. Absolute dynamite!
I have seen this behavior on Solaris  (x86 and SPARC) versions of thunderbird as 
well.  It happens when replying to another message and highlighting
sections of the message and then either hitting BS or DEL to get rid
of the highlighted text.
prob dupe of bug 304720.
can you test for this using 2.0 and report back?
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8/
Severity: normal → critical
Keywords: crash
Summary: Using Delete key in reply under certain circumstances causes crash → delete text in message reply under certain circumstances causes crash
QA Contact: message-compose
(In reply to comment #3)
I can not recreate this problem in Thunderbird 2.0 for Mac or Linux.
bug 304720 was "Verified fixed on the 1.8.0 branch using version 1.5.0.2 (20060308) following the reporter's STR."

duping
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 304720
You need to log in before you can comment on or make changes to this bug.