Closed Bug 333282 Opened 19 years ago Closed 19 years ago

firefox 1.5.0.2 universal binary crashes (due to iPhotoPhotocast.plugin?)

Categories

(Core Graveyard :: Plug-ins, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 332704

People

(Reporter: bugzilla, Assigned: mark)

References

()

Details

Attachments

(1 file)

http://www.bioneural.net/2005/12/23/the-elusive-multi-device-video-format/

I'm running Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.2) Gecko/20060328 Firefox/1.5.0.2


Date/Time:      2006-04-08 22:10:53.958 -0700
OS Version:     10.4.5 (Build 8G1454)
Report Version: 4

Command: firefox-bin
Path:    /Users/seth/Desktop/ff ub/Firefox.app/Contents/MacOS/firefox-bin
Parent:  WindowServer [57]

Version: 1.5.0.2 (1.5.0.2)

PID:    6691
Thread: Unknown

Link (dyld) error:

no suitable image found.  Did find:
	/Library/Internet Plug-Ins/iPhotoPhotocast.plugin: not a file
Model: iMac4,1, BootROM IM41.0039.B00, 2 processors, Intel Core Duo, 2 GHz, 2 GB
Graphics: ATI Radeon X1600, ATY,RadeonX1600, PCIe, 256 MB
Memory Module: DIMM0/BANK 0, 1 GB, DDR2 SDRAM, 667 MHz
Memory Module: DIMM1/BANK 1, 1 GB, DDR2 SDRAM, 667 MHz
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x89), 101.3 (3.120.28.3)
Bluetooth: Version 1.7.2f10, 2 service, 1 devices, 2 incoming serial ports
Network Service: Built-in Ethernet, Ethernet, en0
Serial ATA Device: Maxtor 6L250M0, 233.76 GB
Parallel ATA Device: MATSHITADVD-R   UJ-846
USB Device: Built-in iSight, Micron, Up to 480 Mb/sec, 500 mA
USB Device: Hub in Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 500 mA
USB Device: Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 250 mA
USB Device: Bluetooth HCI, Up to 12 Mb/sec, 500 mA
USB Device: IR Receiver, Apple Computer, Inc., Up to 12 Mb/sec, 500 mA
we need to change how we use ld so that it stops killing us when it doesn't like the files we try to load. *grumble*
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: 1.5.0.x Branch → Trunk
This has nothing to do with ld, it's the plugin loader in ns4xPlugin.
Actually, it's not even that.  There's an apparent bug in CrashReporter, causing it to pinpoint the last dyld error encountered, even though the dyld error wasn't fatal (we handled it).

The real reason for the crash is a divide-by-zero.  I noticed SIGFPE was delivered, which is not typical of dyld assertions (SIGTRAP).  In the debugger, this proved to be crashing in nsImageMac::LockImagePixels.
Assignee: nobody → mark
Attached file Real stack backtrace
This was taken from a trunk build with the patch from bug 332704 bypassed.

*** This bug has been marked as a duplicate of 332704 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
rdar://4507843 for the CrashReporter issue.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: