Closed Bug 333303 Opened 14 years ago Closed 14 years ago

useless null check of fd in nsComponentManagerImpl::WritePersistentRegistry

Categories

(Core :: XPCOM, defect, trivial)

x86
Linux
defect
Not set
trivial

Tracking

()

RESOLVED FIXED

People

(Reporter: timeless, Assigned: asqueella)

References

(Blocks 1 open bug, )

Details

(Keywords: coverity)

Attachments

(1 file)

found by coverity

this is my fault, i was being too careful in rev 1.213

fd can't be null because if fd becomes null in 1303, the code takes the path in 1304-1305. any path after that point leaves fd non null so it should be cleaned up unconditionally.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → asqueella
Status: NEW → ASSIGNED
Attachment #217744 - Flags: review?(timeless)
Attachment #217744 - Flags: superreview?(darin)
Attachment #217744 - Flags: review?(timeless)
Attachment #217744 - Flags: review+
wasn't this patch included in that other patch?
Oops. I could have sworn I removed it from that patch.
Attachment #217744 - Flags: superreview?(darin)
This was checked in as part of patch on bug 333307, then.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.