Closed Bug 333313 Opened 18 years ago Closed 18 years ago

oom mlk in InternetSearchDataSource::BeginSearchRequest

Categories

(SeaMonkey :: Search, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0a1

People

(Reporter: timeless, Assigned: philor)

References

()

Details

(Keywords: coverity, memory-leak)

Attachments

(1 file)

found by coverity

this bug dates to rev 1.89

things to do:
1. fix the code to honor the comment which dates to rev 1.17 or earlier so that it stops leaking.
2. fix the comment to use it's and its properly:

3189                        // if its a engine from a search category, then get its "#Name",

if it's (it is) an engine from a search category then get its (possessive) "#Name",

(there are two changes to the line, don't just fix its).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch Fix v1Splinter Review
rev 1.17 indeed: as timeless said, since NS_RDF_NO_VALUE means trueEngine's still nsnull, it was fine as it was then.
Assignee: search → philringnalda
Status: NEW → ASSIGNED
Attachment #218154 - Flags: superreview?(jag)
Attachment #218154 - Flags: review?(timeless)
Attachment #218154 - Flags: review?(timeless) → review+
Attachment #218154 - Flags: superreview?(jag) → superreview+
Whiteboard: [checkin needed]
mozilla/xpfe/components/search/src/nsInternetSearchService.cpp 	1.248
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → mozilla1.9alpha
Product: Core → SeaMonkey
Target Milestone: mozilla1.9alpha1 → seamonkey2.0a1
You need to log in before you can comment on or make changes to this bug.