mlk for class nsINIParser

RESOLVED WONTFIX

Status

Core Graveyard
Installer: XPInstall Engine
RESOLVED WONTFIX
12 years ago
3 years ago

People

(Reporter: timeless, Unassigned)

Tracking

({coverity, memory-leak})

Trunk
x86
Linux
coverity, memory-leak

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
found by coverity

afaik nothing frees mFileBuf
(Reporter)

Comment 1

12 years ago
note this code also appears in mozilla/toolkit/mozapps/installer/unix/wizard/nsINIParser.cpp because we love forking code. coverity expects both places to be fixed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 242394 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 3

12 years ago
That bug only has patches for xpinstall/, let's track the issues separately.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

12 years ago
Do people still care mozilla/toolkit/mozapps/installer/unix/ ?  Isn't it not being shipped?

If people still care about it, I'd port the stuff I did with the suite installer over after the fork.

Comment 5

12 years ago
The toolkit/ code is gone.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.