Memory leak in DOM Inspector on 1.8 branch

RESOLVED DUPLICATE of bug 336961

Status

RESOLVED DUPLICATE of bug 336961
13 years ago
12 years ago

People

(Reporter: JasnaPaka, Unassigned)

Tracking

({memory-leak})

1.8 Branch
x86
All
memory-leak

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060406 Firefox/2.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060406 Firefox/2.0a1

1. Run Firefox on new profile.
2. Choose Tools -> DOM Inspector im mainmenu.
3. Close DOM Inspector and Firefox


Reproducible: Always

Actual Results:  
Leaked outer window 14e6430 at address 14e6430.
Leaked inner window 14fd0a8 (outer 14e6430) at address 14fd0a8.
 ... with URI "about:blank".
Leaked document at address 27402d0.
 ... with URI "chrome://inspector/content/extensions/titledSplitter.xml".
 ... with URI "jar:file:///C:/Programy/Mozilla%20Firefox%202/extensions/inspector@mozilla.org/chrome/inspector.jar!/content/inspector/extensions/titledSplitter.xml".
Leaked document at address 27847f0.
Leaked document at address 268f4d0.
Leaked document at address 27a6c90.
Leaked document at address 261e7b0.
 ... with URI "jar:file:///C:/Programy/Mozilla%20Firefox%202/extensions/inspector@mozilla.org/chrome/inspector.jar!/content/inspector/inspector.xml".
 ... with URI "chrome://inspector/content/inspector.xml".
Leaked document at address 2758858.
 ... with URI "about:blank".
Summary:
Leaked 2 out of 15 DOM Windows
Leaked 6 out of 43 documents
Leaked 0 out of 7 docshells
(Reporter)

Updated

13 years ago
Keywords: mlk

Comment 1

13 years ago
Confirming, 1.8 branch only.

This grows each time you open the DOM Inspector (Leaked 2+4n out of .. documents where n = however many times you open it)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.8.1?
OS: Windows XP → All
Summary: Memory leak in DOM Inspector → Memory leak in DOM Inspector on 1.8 branch
Version: unspecified → 1.8 Branch

Comment 2

13 years ago
does this happen w/ suite?
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> does this happen w/ suite?

Same problem with SeaMonkey 1.1a.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060518 SeaMonkey/1.1a

All works fine with SeaMonkey 1.5a.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060521 SeaMonkey/1.5a

Updated

13 years ago
Flags: blocking1.8.1? → blocking1.8.1+

Comment 4

13 years ago
Is this not a dupe of bug 336961 (which has yet to be landed on the branch). Leak Monitor shows it's leaking the observer from dom.js...
  PrefUtils.addObserver("inspector", PrefChangeObserver);
without any removeObserver call seems suspicious.  Is the PrefChangeObserver what leak-monitor shows as leaking?

Seems like a duplicate of bug 336961.

Comment 6

13 years ago
(In reply to comment #5)
> Is the PrefChangeObserver what leak-monitor shows as leaking?

Yep. Duping.



*** This bug has been marked as a duplicate of 336961 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Clearing flag on bug marked duplicate (duplicate is plussed too).
Flags: blocking1.8.1+
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.