mozilla & firefox seg fault on a Tektronix X Terminal.

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
critical
RESOLVED INCOMPLETE
12 years ago
7 years ago

People

(Reporter: Phil White, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060226 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060226 Firefox/1.5

From an X Terminal, I use a terminal window to telnet to another system.  I export my DISPLAY variable.  I can start xclock, dillo, openoffice, and most any other program I choose.  Firefox segfaults.  Session follows:
---
$ export DISPLAY="10.0.0.5:0"
$ firefox
/usr/lib/mozilla-firefox/mozilla-xremote-client: Error: Failed to find a running server.
/usr/lib/mozilla-firefox/mozilla-xremote-client: Error: Failed to find a running server.
No running windows found
/usr/libexec/mozilla-launcher: line 119: 29383 Segmentation fault      "$mozbin" "$@"
firefox-bin exited with non-zero status (139)
---

Reproducible: Always

Steps to Reproduce:
1. From a Tektronix X term, telnet to an X capable system
2. export DISPLAY
3. start firefox

Actual Results:  
$ export DISPLAY="10.0.0.5:0"
$ firefox
/usr/lib/mozilla-firefox/mozilla-xremote-client: Error: Failed to find a running server.
/usr/lib/mozilla-firefox/mozilla-xremote-client: Error: Failed to find a running server.
No running windows found
/usr/libexec/mozilla-launcher: line 119: 29383 Segmentation fault      "$mozbin" "$@"
firefox-bin exited with non-zero status (139)

Expected Results:  
It should have brought up a window.

It used to work with previous versions.  

A friend of mine mentioned something weird where he was on machine A, ssh'd to B, forwarded his display, used firefox, and while that session was still running, went to machine B, forwarded his display to machine A, and it somehow sniffed out the previous session.  If this were the case, it wouldn't shock me if mozilla tried to do that discovery and it failed because the X Term in question is a rather singular bit of equipment.

Comment 1

8 years ago
Can reporter please let us know if fault still occurs with recent Firefox version.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.