Javascript Problem (Alert twice should be once)

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
12 years ago
8 years ago

People

(Reporter: TeraKhir Wih, Unassigned)

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla 1.5.0.1

If I enter data for Thickness 1 Part 2 and others, then the value is less than or more than control limit that I define in javascript it will prompt alert mesage which I put in the script. But the prompt should be 1 times, but in firefox the alert  message propmt twice and go to the next field.  

Reproducible: Always

Steps to Reproduce:
1. Focus the Thickness 1 part 1, enter value 2.273 in the prompt box.
2. Then click ok, it will go to the next field. 
3. At the propmt of the field enter value 2.261.
4. Press ok, the alert appear.
5. Then the prompt alert should go to the next field.
6. But the alert apear 1 more time. (It Should be no 1 more time but direcly go to next field.
7. Then press ok, it will go to the next field. 

Actual Results:  
The alert apear twice.

Expected Results:  
It will prompt alert once and go to other textfield.
(Reporter)

Comment 1

12 years ago
Created attachment 217830 [details]
This attachement contain the html files than contain bug in Firefox.
Reporter, can you please make a reduced testcase? That is, a testcase that contains the _bare minimum_ of code in order to replicate the problem? Thanks!

Comment 3

12 years ago
With such a complicated testcase you can believe that there is a javascript programing problem and not a bug ;) Try to factorize your code or send a more minimal testcase :)
Please file a new bug with the simplest testcase that can be used to reproduce the issue, and this should be in Core, not Firefox
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

12 years ago
I have try this javascript code in Internet Explorer. It never happen as in the Firefox. I have try the to modify the code.  The problem occur from the switch test case. But I also try to use if else test case the result still the same. But, what ever, I stop debuging my javascript because my friend test it under Internet Explorer 6.0, it's run smoothly. So, because of that I stop debuging and assume it is a bug in Mozilla Firefox. What ever, I will try to minimize the code. But please take surious action to this problem because beside Firefox, no better choice that will run in multiple OS. 
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 6

12 years ago
Assuming this is a bug in firefox just because it works in IE is wrong. There are lots examples demonstrating the opposite. It is very unlikely any action will be taken on this bug until a minimal testcase is attached (because if you don't make the minimal testcase, someone else will have to do it for you, and few people have time for that.)
Component: Error Console → General
Product: Firefox → Core
QA Contact: javascript.console → general
Summary: Javascript Problem (Alert twice shold be once) → Javascript Problem (Alert twice should be once)
Version: unspecified → 1.8 Branch

Comment 7

8 years ago
Sorry, no point in keeping this open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.