Closed Bug 333510 Opened 19 years ago Closed 18 years ago

Contacts Sidebar comes up empty

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird2.0

People

(Reporter: mscott, Assigned: mscott)

References

()

Details

(Keywords: fixed1.8.1, regression, verified1.8.1.3)

Attachments

(1 file)

Not sure when this regression first started.

If you have the contacts sidebar open in the compose window, and you bring up a compose window, the address book is selected but entries aren't displayed. Oddly enough, quick search within the sidebar does show the results in the results pane.
Keywords: regression
the problem is specific to cached compose windows.
This was caused by Bug 321254. when we open a cached compose window, we end up calling AbPanelOnComposerClose()  which closes the abview on the contacts panel.
Attached patch the fixSplinter Review
this patch restores the view when we re-open the cached compose window.
Attachment #222283 - Flags: superreview?(bienvenu)
Attachment #222283 - Flags: superreview?(bienvenu) → superreview+
fixed trunk and branch.
Blocks: 321254
Status: NEW → RESOLVED
Closed: 18 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
verified fixed 1.8.1.3 using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 ID:2007032620 and the steps to reproduce from comment#0
Keywords: verified1.8.1.3
Depends on: 364815
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: