In DEC/OSF1 build failure in mozilla/xpcom/stub directory

RESOLVED FIXED

Status

Firefox Build System
General
--
major
RESOLVED FIXED
12 years ago
3 months ago

People

(Reporter: Laxmi Harikumar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: 

Mozilla build is failing in xpcom/stub directory with the following error:

cxx  -noexceptions -ieee -ptr ../../dist/cxx_repository -pthread  -DDEBUG -D_DEB
UG -DDEBUG_dailybld -DTRACING -g  -shared -msym -expect_unresolved \* -update_re
gistry ../../dist/so_locations -soname libxpcom.so -o libxpcom.so  nsXPComStub.o
    -lpthread          -L../../dist/bin -L../../dist/lib -Wl,-rpath-link,../../d
ist/bin -lxpcom_core -L../../dist/lib -lplds4 -lplc4 -lnspr4 -lpthread -lm -lc_r

ld (prelink):
-rpath-link: Unknown flag
ld: Usage: ld [options] file [...]
ld:
-rpath-link: Unknown flag
ld: Usage: ld [options] file [...]
gmake[5]: *** [libxpcom.so] Error 1
gmake[5]: Leaving directory `/usr4/dailybld/mozilla/xpcom/stub'


Reproducible: Always

Steps to Reproduce:
1. Go to mozilla/xpcom directory
2. Run make
3.

Actual Results:  
Build fails

Expected Results:  
Build should have completed without any errors

As mentioned in comment#6 Bug 332053,

this problem is caused by the modification of autoconf.mk.in file.
(Reporter)

Updated

12 years ago
OS: Other → OSF/1
Hardware: Other → DEC
(Reporter)

Comment 1

12 years ago
Created attachment 218000 [details] [diff] [review]
Patch for configure file

The solution is to override MOZ_FIX_LINK_PATHS for osf in configure file

Updated

12 years ago
Attachment #218000 - Flags: review?(cls)

Comment 2

12 years ago
You almost certainly need a real replacement for fix-link-paths; see bug 332075 for what this variable needs to be able to do.
Status: UNCONFIRMED → NEW
Ever confirmed: true
and don't modify configure directly, it's autogenerated from configure.in.

Comment 4

12 years ago
Comment on attachment 218000 [details] [diff] [review]
Patch for configure file

MOZ_FIX_LINK_PATHS needs to be set in the $target section, not the $host section (yes, darwin & os2 are bad examples).  The patch needs to be against configure.in, not configure.  I know that OSF1 supports -rpath.  Is that a suitable substitute or would we wind up hardcoding in a temporary build path?
Attachment #218000 - Flags: review?(cls) → review-

Comment 5

12 years ago
-rpath would end up hardcoding bad paths.
(Reporter)

Comment 6

12 years ago
Created attachment 218649 [details] [diff] [review]
Patch in configure.in file

Thanks for the review comments.
As per the comments, I have put the patch in the $target section of configure.in. Also I am not using "-rpath" as a substitute.
Attachment #218000 - Attachment is obsolete: true

Updated

12 years ago
Attachment #218649 - Flags: review+

Comment 7

12 years ago
Checking in configure.in;
/cvsroot/mozilla/configure.in,v  <--  configure.in
new revision: 1.1691; previous revision: 1.1690
done
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

3 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.