Thunderbird extensions on web site keep getting moved

RESOLVED DUPLICATE of bug 332843

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED DUPLICATE of bug 332843
12 years ago
2 years ago

People

(Reporter: Eric Moore, Assigned: morgamic)

Tracking

x86
Windows XP

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I've written numerous knowledge base articles on the Mozillazine web site that link to extensions on https://addons.mozilla.org/thunderbird/ . However, I've been finding that sometimes the URL becomes useless because the extension is moved. For example, http://kb.mozillazine.org/International_characters has a link for the Thunderbird abcTajpu extension at  https://addons.mozilla.org/extensions/moreinfo.php?application=thunderbird&numpg=10&id=459&numpg=50
I now find that its no longer on the Thunderbird portion of the web site, its on the Firefox portion of the web site at https://addons.mozilla.org/addon.php?id=459 , with the text mentioning it works with both Thundebird and Firefox. I'll edit the knowledge base article to use the new URL but not being able to trust the URL makes it harder to maintain knowledge base articles. One sideffect is nowadays I point to the authors web site whenever possible, instead of Mozillas. 

I can only assume this is yet another example of the Firefox bias on the Mozilla update web site. Please provide some way to link to an extensions web page that won't break.

Reproducible: Always

Actual Results:  
A summary page of recently updated and top rated thunderbird extensions is displayed instead of the extensions web page

Expected Results:  
Brwoser displays the extensions web page.

If you decide to move extensions, please redirect the old URL to the new URL so that you don't break any links in the knowledge base or other web pages that point to an extension.

Comment 1

12 years ago
The addons site has recently been completely revamped. All the URLs have changed. We are sorry for the inconvenience, but the update fixes more stuff than it breaks. "keep getting moved" is a bit over the top I think - this is the first time URLs have changed afaik.

You can use https://addons.mozilla.org/addon.php?id=459&app=thunderbird or https://addons.mozilla.org/thunderbird/459 to link to the extension specifically for thunderbird if you so choose, we are not at all biased towards Firefox.

*** This bug has been marked as a duplicate of 332843 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

12 years ago
Thanks for the reply. This isn't the first URL change I've run into. Please note that if I search for the extension I gave as an example it only returns it for the Firefox add-on web site. I noticed that

https://addons.mozilla.org/addon.php?id=459 goes to Firefox
https://addons.mozilla.org/thunderbird/459 goes to Thunderbird.

so it looks like in general what I have to do is search for the extension, and modify the URL when it finds it on the Firefox add-on web site to point to the Thunderbird add-on web site. Even the enigmail extension is returned on the Firefox add-ons web site! While it doesn't matter to me which web site its on I've found it does confuse other users. 

The only change I've noticed in the updated site is the green rating boxs in the comments, and some of the colors seem different.

Comment 3

12 years ago
Organising bugs. Sorry for the bugspam.
Version: unspecified → 2.0
(Assignee)

Comment 4

12 years ago
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
AMO BUGSPAM FOR QACONTACT FIX (FILTER ME)
QA Contact: listings → web-ui
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.