VersionCheck.php - incorrect version comparison

VERIFIED DUPLICATE of bug 292138

Status

VERIFIED DUPLICATE of bug 292138
13 years ago
3 years ago

People

(Reporter: gomita, Assigned: morgamic)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

My extension, ScrapBook uses addons.mozilla.org for 'updateURL' and I 
recently updated the version from "1.0pre" to "1.0".
I believe version "1.0" is higher than "1.0pre".
However, now I'm facing the following problem.

Reproducible: Always

Steps to Reproduce:
1. Install ScrapBook 1.0pre
2. Try to find updates with Extension Manager
Actual Results:  
Extension Manager requests to:
https://addons.mozilla.org/update/VersionCheck.php?id={%GUID%}&version=1.0pre&...
and the response is:
...<em:version>1.0pre</em:version>...
then it says "No updates were found for ScrapBook".

Expected Results:  
The response should be:
...<em:version>1.0</em:version>...
and it should say "A new version of ScrapBook (1.0) is available.".
Assignee: nobody → morgamic
Component: Server Operations Projects → Web Site
Product: mozilla.org → Update
QA Contact: justin → web-ui
Target Milestone: --- → 2.1
Version: other → 2.0

Comment 2

13 years ago
There are several open bugs for versioning.  

*** This bug has been marked as a duplicate of 292138 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

13 years ago
This could also be a result of caching.

AMO v2 doesn't compare the varchar anymore and goes off of vID so if you're not getting any updates it's most likely that the old update was cached, and you need to wait for the cache timeout, which is longer than most other pages due to how hard the update script gets hit.

Updated

13 years ago
Status: RESOLVED → VERIFIED
Target Milestone: 2.1 → ---
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.