parser now requires some end tags when before it didn't

VERIFIED FIXED

Status

()

Core
HTML: Parser
P2
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: karnaze (gone), Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
If an <option>, <tbody>, <thead>, <tfoot>, or <tr> appears in a table and there
is no corresponding end tag then the content model gets messed up if there are
subsequent table related elements. Extra nested tables get created. The
following illustrates the case where </tr>s are missing. This was run with a
2/27 am NT build. I filed a bug a few days ago for the case of a missing
<tbody>, but this is getting serious enough to warrant another bug.

<table border=1>
<tbody>
<tr><td>tbody-1 cell-1<td>tbody-1 cell-2
</tbody>
<tbody>
<tr><td>tbody2 cell</tr>
</tbody>
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
QA Contact: 3847 → 4141

Comment 1

20 years ago
reassigning QA Contact to Germaine.
(Reporter)

Comment 2

20 years ago
I'm adding Troy's comments from bug 3436 and marking that one a duplicate of
this.

The very bottom example of test4 isn't displaying correctly, because the
collapsed version of the table is getting incorrectly nested inside the previous
table.

This small subset of HTML demonstrates the problem. If you add </tr> to each
line (eight places), then it's not nested and it displays okay.

<P> The following table will have its 1st row group collapsed (rows 1 and 2)
<BR>
<table cellspacing=0 border=1 style="background-color:orange;">
<caption><b>before</b></caption>
<tbody style="background-color:red;">
<tr><td>C11<td>C12<td>C13<td>C14
<tr><td>C21<td>C22<td>C23<td>C24
</tbody>
<tbody>
<tr><td>C31<td>C32<td>C33<td>C34
<tr><td>C41<td>C42<td>C43<td>C44
</tbody>
</table>

<BR>
<table cellspacing=0 border=1 style="background-color:orange;">
<caption><b>after</b></caption>
<tbody style="visibility:collapse;">
<tr><td>C11<td>C12<td>C13<td>C14
<tr><td>C21<td>C22<td>C23<td>C24
</tbody>
<tbody>
<tr><td>C31<td>C32<td>C33<td>C34
<tr><td>C41<td>C42<td>C43<td>C44
</tbody>
</table>
(Reporter)

Comment 3

20 years ago
*** Bug 3436 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

20 years ago
Fixed by improvements to elementtable.

Updated

20 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.