Last Comment Bug 333633 - Need to enable relocations when linking the binary for profiling
: Need to enable relocations when linking the binary for profiling
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 14:28 PDT by Stuart Parmenter
Modified: 2015-03-17 10:36 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Stuart Parmenter 2006-04-11 14:28:10 PDT
Most profilers (VTune and Quantify) are much happier if we pass /FIXED:NO to LDFLAGS in browser/app/Makefile.in.

Should we do it with a new config flag or just always do it with --enable-debugger-info-modules set?
Comment 1 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2006-04-11 14:32:22 PDT
Test _DEBUG_CFLAGS, and if that is set add the flag.
Comment 2 Stuart Parmenter 2006-04-11 14:36:17 PDT
Does that work with:  --enable-optimize --disable-debug --enable-debugger-info-modules
?
Comment 3 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2006-04-11 14:39:03 PDT
yes, see http://lxr.mozilla.org/mozilla/source/config/config.mk#193
Comment 4 Darin Fisher 2006-04-11 15:20:51 PDT
Will this help in the case of a static executable as well?  It's tough to make sense of Quantify results when I profile a static build.
Comment 5 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2006-04-11 15:30:13 PDT
If the static build has --enable-debugger-info-modules=all, yes
Comment 6 Jukka Jylänki 2015-02-26 04:55:00 PST
Hey, this is a very old bug, and I wonder if this is still needed, or if we can close this?

I am looking at this documentation on VTune support for Firefox: https://developer.mozilla.org/en-US/docs/Profiling_with_VTune , and I was able to build a VTune-enabled build of Firefox on Windows with the following .mozconfig (not all flags below are relevant, but pasting it in full to be exact):

ac_add_options --enable-debug-symbols
ac_add_options --enable-vtune
ac_add_options --enable-profiling    # This is implied by --enable-vtune, so was redundant.
ac_add_options --disable-tests

ac_add_options --target=x86_64-pc-mingw32
ac_add_options --host=x86_64-pc-mingw32

Looking at the generated VTune profile, I am seeing JS code interleaved with C++ code, which is nice (although there's something that looks a bit fishy, but that's probably story for another bug).

The reason I am asking is that I want to bring the VTune MDN page up to date with new flags, and I am wondering whether I can remove the reference on that page to this bug? I'm thinking yes, but just wanted to confirm.
Comment 7 Ted Mielczarek [:ted.mielczarek] 2015-03-17 10:36:09 PDT
If VTune works for you then that seems fine.

Note You need to log in before you can comment on or make changes to this bug.