Closed Bug 333641 Opened 16 years ago Closed 16 years ago

Duplicate GET or POST with no request parameters

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 316731

People

(Reporter: bmckee, Unassigned)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

In some, but not all, of my web applications...when using Firefox...the GET or POST will fire twice.  I thought I had narrowed this down to using Tiles or Sitemesh but I have an application that uses neither of those and still has this problem.  The request comes through with the parameters.  The response is sent.  Then another request comes through (with no parameters).  There is no response from this because it has already been sent.  The second request causes the web application to run through it's logic again with null parameters.  When using sessions this causes null data to be stored in the session.

Reproducible: Always

Steps to Reproduce:
1.Submit form (add something to your web app to output some text for each submit).
2.
3.

Actual Results:  
I can see two GET or two POST requests in the web server logs.

Expected Results:  
Only one GET or POST should occur.
Dupe of bug 316731?
This was due to an img tag with no source.  I was updating the source with javascript to support our web page where we would dynamically change the image and associated url for rotating ads.  I used a default image source (blank jpeg) and this problem went away.  THANK YOU SO MUCH...THIS HAS BEEN HAUNTING US FOR QUITE SOME TIME!

*** This bug has been marked as a duplicate of 316731 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.