Closed Bug 333651 Opened 15 years ago Closed 15 years ago

URL bar doesn't get focus when opening a new tab

Categories

(Firefox :: Tabbed Browser, defect)

2.0 Branch
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 2 alpha2

People

(Reporter: easterlingman, Assigned: steffen.wilberg)

References

Details

(Keywords: fixed1.8.1, regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8) Gecko/20060411 Firefox/2.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8) Gecko/20060411 Firefox/2.0a1

When opening a new tab the URL bar doesn't get focus like it should.. this only happens when opening a new tab, not when opening a new window

Reproducible: Always

Steps to Reproduce:
1. open new tab
2. try to type in URL
3. realize that the URL bar isn't in focus
branch-only

regressed between 20060410 and 20060411
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox2?
Keywords: regression
Version: unspecified → 2.0 Branch
Seeing this in the JS Console when using Ctrl+T or when switching between tabs, also occuring in 'Safe Mode' 

Error: BrowserController.onTabSwitch is not a function
Source file: chrome://browser/content/browser.xul
Line: 1

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060411 Firefox/2.0a1 ID:2006041103
Blocks: 329733
With today's build, now I'm seeing XML errors in the JS Console: 
Warning: Event=popupshowing, use of preventBubble() is deprecated. Use W3C standard stopPropagation() instead.
Source file: chrome://browser/content/browser.xul

Along with the error reported yesterday:
Error: BrowserController.onTabSwitch is not a function
Source file: chrome://browser/content/browser.xul
Line: 1



Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060412 Firefox/2.0a1 ID:2006041204
Jim, that's not related to this bug and is probably caused by an extension since we don't use preventBubble anymore (bug 330710): http://lxr.mozilla.org/mozilla1.8/search?string=preventBubble
(In reply to comment #5)
> Jim, that's not related to this bug and is probably caused by an extension
> since we don't use preventBubble anymore (bug 330710):
> http://lxr.mozilla.org/mozilla1.8/search?string=preventBubble
> 

Sorry, TabMix Plus dev version 0.3.0.604 causing the errors in XML, strange I did not see them yesterday.  I will file a report with the author.
Attached patch patchSplinter Review
One-liner, merges trunk to branch.
Assignee: nobody → steffen.wilberg
Status: NEW → ASSIGNED
Attachment #218197 - Flags: review?(bugs)
Attachment #218197 - Flags: approval-branch-1.8.1?(bugs)
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Firefox 2 alpha2
I can verify that the patch fixes the problem.  I just did a new build with the patch included, and everything is back to normal...including the problem of the bookmark menu staying open when middle-clicking an entry to open a bookmark in a new tab.
*** Bug 333804 has been marked as a duplicate of this bug. ***
Comment on attachment 218197 [details] [diff] [review]
patch

r+a=ben@mozilla.org
Attachment #218197 - Flags: review?(bugs)
Attachment #218197 - Flags: review+
Attachment #218197 - Flags: approval-branch-1.8.1?(bugs)
Attachment #218197 - Flags: approval-branch-1.8.1+
Looks like this is already in the trunk, can you check in on the branch asap? Thanks for the quick help!
Checked in on branch.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Flags: blocking-firefox2?
Keywords: fixed1.8.1
Resolution: --- → FIXED
*** Bug 333956 has been marked as a duplicate of this bug. ***
Verified with Windows and Mac 2.0b1rc3 builds
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.