After clicking on bookmark folder in Personal Toolbar, bookmarks in the expanded folder cannot be selected until mouse button is released

RESOLVED DUPLICATE of bug 324963

Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 324963
12 years ago
12 years ago

People

(Reporter: Rob Hulswit, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060411 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060411 SeaMonkey/1.5a

When I click on a bookmark folder on the Personal toolbar, no bookmarks are selected until the mouse button is released. The previous behaviour was that bookmarks were selected, and that on releasing the left mouse button the current selected bookmark was opened. This was quite a fast way of opening a bookmark in a folder with one click; now you need to click twice
I would like that behaviour back...

Reproducible: Always

Steps to Reproduce:
1. Create bookmark folder in personal toolbar, insert a bookmark into the folder
2. Click on the bookmark folder, don't release the mouse button
3. Hover over the bookmark within the folder
4. Release the mouse button over the bookmark within the folder

Actual Results:  
In step 2, the bookmark folder is opened
In step 3 and 4, nothing happens at all.

Expected Results:  
After step 3, the bookmark within the folder should have been selected.
After step 4, the bookmark within the folder should have been opened.


The same problems happens with the main menu; it is probably a menu problem.

Comment 1

12 years ago
WFM with SeaMonkey 1.5a/2006012409 (and SeaMonkey 1.5a/2006012510 afaict) but reproducible with SeaMonkey 1.5a/2006012609.

Updated

12 years ago
Keywords: regression
Version: unspecified → Trunk
confirming

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060404 SeaMonkey/1.5a Mnenhy/0.7.3.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
This happens in all my menus, not just bookmark-related ones.
Component: Bookmarks → XP Apps: GUI Features

Comment 4

12 years ago
dupe of "Menu highlight is broken/doesn't show up/not painted on mouse drag"

*** This bug has been marked as a duplicate of 324963 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Component: XP Apps: GUI Features → Bookmarks
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.