All users were logged out of Bugzilla on October 13th, 2018

Weekly recurring event displayed on wrong day (one day early)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: jason_mozbugzilla, Unassigned)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8; clicket) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060411 Mozilla Sunbird/0.3a1+ - Build ID: 2006041106

Creating a weekly recurring event seems to generate the proper VEVENT code, but is interpreted incorrectly in all calendar views.

Reproducible: Always

Steps to Reproduce:
1. Create an event on a Thursday.
2. Set it to recur every 1 week on Thursday.
3. Close Sunbird.
4. Open Sunbird.

Actual Results:  
The recurring events are displayed on Wednesday after restarting Sunbird.

Expected Results:  
The recurring events should be displayed on Thursday.
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk
Can you attach the generated ics to this bug?
(Reporter)

Comment 2

13 years ago
BEGIN:VEVENT
CREATED:20060412T112230Z
LAST-MODIFIED:20060412T112248Z
DTSTAMP:20060412T112248Z
UID:uuid1144840968497
SUMMARY:Test Event
PRIORITY:0
CLASS:PUBLIC
RRULE:FREQ=WEEKLY;INTERVAL=1;BYDAY=TH
DTSTART;TZID=/mozilla.org/20050126_1/America/Cancun:20060406T200000
DTEND;TZID=/mozilla.org/20050126_1/America/Cancun:20060406T210000
END:VEVENT
(Reporter)

Comment 3

13 years ago
I've gone back over this several times.  This bug shows up when the event is after 6:59PM.
*** Bug 333717 has been marked as a duplicate of this bug. ***
That looks like a timezone issue... Given that this is dataloss, marking as blocking 0.3a2
Blocks: 330188
Keywords: dataloss
Jason: Can you check what sunbird thinks your timezone is? (You need to use a build from tomorrow, one that has bug 304541 fixed). And what timezone is your computer set to?
I can't repoduce the bug on my linux system, but i didn't change my system timezone. I'll retest in my windows vmware once the new builds are available.
I can't reproduce the bug. Maybe it's fixed by bug 333717. Jason, can you confirm?

Removing this bug from the blocker list, because it's unlikely to hit a lot of people, if it isn't already fixed.
No longer blocks: 330188
(Reporter)

Comment 8

13 years ago
This now works for me.  Whose responsiblity is it to close (tag as "fixed") this bug?
Marking as worksforme, because there is no real fix in this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have struck again. They are currently chewing on default assignees for Calendar. Be afraid for your sanity!
Assignee: base → nobody
You need to log in before you can comment on or make changes to this bug.