Recurring events that cross a Daylight Saving Time change display the wrong time

RESOLVED WORKSFORME

Status

Calendar
Internal Components
RESOLVED WORKSFORME
12 years ago
3 years ago

People

(Reporter: Jason Brewer, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8; clicket) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060411 Mozilla Sunbird/0.3a1+ - Build ID: 2006041106

A recurring event that starts before a Daylight Saving Time change will reflect a one hour error after the change.

Reproducible: Always

Steps to Reproduce:
1. Change the Sunbird timezone to America/Chicago (which shows up as America/Cancun in the VEVENT code for some reason).
2. Create an event on Saturday, April 1, 2006 at 8:00PM.
3. Close Sunbird.
4. Open Sunbird.

Actual Results:  
The second occurrence is displayed as occurring at 9:00PM (as well as all occurrences between April 2, 2006 and October October 29, 2006).

Expected Results:  
Should be displayed as 8:00PM.

This appears to only occur for a calendar stored on a WebDAV share.  I can't get a local calendar to reproduce the bug.  I'm using Apache 2.0.52 on the server side.  I've created new Remote calendars with the same result.
It seems that the check in for Bug 333717 fixed this problem too.

  Fails with sunbird-0.3a1+.en-US.win32-2006-04-18-07-trunk
  Works with sunbird-0.3a1+.en-US.win32-2006-04-19-07-trunk

Jason: Can you retest please with a current nightly build too?
(Reporter)

Comment 2

12 years ago
This works for me now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have struck again. They are currently chewing on default assignees for Calendar. Be afraid for your sanity!
Assignee: base → nobody

Comment 4

3 years ago
Seems like this bug has revived! On my Thunderbird 31.6.0 on Ubuntu Gnome 14.10 with Lightning 3.3.3 I created events on february and after the Daylight Saving Time change the events are shown as one hour earlier...
You need to log in before you can comment on or make changes to this bug.