IMAP: Shows EMAIL ADDRESSES not DISPLAY NAMES in main Inbox

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
13 years ago
10 years ago

People

(Reporter: rjbinneynospam, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I use an IMAP account.

Regardless of whether or not I check "Display only Display Names from Address Book" in Options, I see the email address of the sender, NOT their Display Name.

I know for a fact folks have Display Names set (verified in OE), and I know that IMAP can show them (again, from OE).

I have done two clean Reinstalls, and still having this problem.

I THINK this is a separate problem from Bug 247333.



Reproducible: Always

Steps to Reproduce:
1.Load TBird
2.Logon to IMAP account
3.Look at Inbox

Actual Results:  
SENDER________________________________________SUBJECT
waitwhat69@yahoo.com__________________________Want to Go Out Tonight?

Expected Results:  
SENDER________________________________________SUBJECT
Simpson, Jessica______________________________Want to Go Out Tonight?

This is the newest install version of TBird. No Extensions added.

Comment 1

12 years ago
The name that's shown in the received message does not have anything to do with the address book, it's taken from the From: header in the message itself.
If you're asking for the address book display name to be used, this is a dupe of bug 243631.

If that's not what you're asking for, then select the message in question and View | Message Source (from the menu).  How does the From: header appear?

You specifically mention IMAP; do you also have a POP account?  If so, does it or does it not exhibit this problem?

Comment 2

12 years ago
Is this IMAP account on AOL?  See bug 331425 & bug 370740 -- a fix was just checked in for those problems, will be in place for TB 2.0.  Not sure if your problem is the same, however.
QA Contact: front-end

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.