nsIParser: Parse(nsIInputStream, ...) doesn't work

VERIFIED INVALID

Status

()

Core
HTML: Parser
P3
normal
VERIFIED INVALID
19 years ago
18 years ago

People

(Reporter: Jonas Utterstrom, Assigned: rickg)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I tried to use the nsIParse::Parse method from my own application:
virtual nsresult  Parse(nsIInputStream& aStream, const nsString&
aMimeType,PRBool aEnableVerify=PR_FALSE, void* aKey=0,eParseMode
aMode=eParseMode_autodetect) = 0;

I get a lot of:
WARNING: Error: possible unintended null in string, file nsString2.cpp, line
1149

And the parser stops before it's finished. Since this method doesn't seem to be
called from Mozilla, maybe it should be removed? I can use the Parse method that
have a nsString argument instead, which works.
It would spare a few outsiders some headache. ;)
jonas.utterstrom@vittran.norrnod.se - has this problem been fixed in recent 
builds? Is the function still there?

Gerv
(Reporter)

Comment 2

18 years ago
Hi,

I've unfortunately lost the test-case for this one but the method is still
there. http://lxr.mozilla.org/seamonkey/source/htmlparser/src/nsIParser.h#207. I
rewrote my test-application to use the Parse method that takes a string as
argument instead.

And I couldn't actually do anything useful with the nsIParse class. Things in
Mozilla are just a little too tied to the UI. I don't care much about this bug.
I could just mark it as INVALID and everyone can go on with more important matters.



Marking INVALID based on reporter's comments.

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 4

18 years ago
marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.