Crash when reading already received mail (popup).

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Bernd Mielke, Assigned: selmer (gone))

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I crashed in a Debug Build made 26.03.2000 at 21:45 GMT when I tried to read an 
already received message. The Inbox seems to be valid. I can view it with the 
notepad.

-	mBufferMgr	0xcdcdcdcd
	__vfptr	CXX0030: Fehler: Ausdruck kann nicht ausgewertet werden
	mSize	CXX0030: Fehler: Ausdruck kann nicht ausgewertet werden
	mBuf	CXX0030: Fehler: Ausdruck kann nicht ausgewertet werden
-	this	0x0403b760
+	nsIMimeEmitter	{...}
+	nsIPipeObserver	{...}
	mRefCnt	0
	_mOwningThread	0x00c910e0
+	m_stringBundle	{...}
+	mBufferMgr	0xcdcdcdcd
+	mOutStream	0xcdcdcdcd
+	mInputStream	0xcdcdcdcd
+	mOutListener	0xcdcdcdcd
+	mChannel	0xcdcdcdcd
	mTotalWritten	3452816845
	mTotalRead	3452816845
+	mPrefs	0xcdcdcdcd
	mDocHeader	-842150451
+	mURL	0xcdcdcdcd
	mHeaderDisplayType	-842150451
+	mHTMLHeaders	{...}
	mAttachCount	-842150451
+	mAttachArray	0xcdcdcdcd
+	mCurrentAttachment	0xcdcdcdcd
+	mHeaderArray	0xcdcdcdcd
+	mEmbeddedHeaderArray	0xcdcdcdcd
+	mHeaderParser	{...}
	mBodyStarted	-842150451
+	mBody	{...}
	mFirstHeaders	1
	mFormat	-842150451
+	mUnicodeConverter	{...}
+	mCharset	{...}

stack trace
nsMimeBaseEmitter::nsMimeBaseEmitter() line 65 + 26 bytes
nsMimeHtmlDisplayEmitter::nsMimeHtmlDisplayEmitter() line 56 + 15 bytes
nsMimeHtmlDisplayEmitterConstructor(nsISupports * 0x00000000, const nsID & 
{...}, void * * 0x0403a500) line 43 + 87 bytes
nsGenericFactory::CreateInstance(nsGenericFactory * const 0x0403a0a0, 
nsISupports * 0x00000000, const nsID & {...}, void * * 0x0403a500) line 48
nsComponentManagerImpl::CreateInstance(nsComponentManagerImpl * const 
0x00c94a80, const nsID & {...}, nsISupports * 0x00000000, const nsID & {...}, 
void * * 0x0403a500) line 1156 + 24 bytes
nsComponentManagerImpl::CreateInstanceByProgID(nsComponentManagerImpl * const 
0x00c94a80, const char * 0x0095f574, nsISupports * 0x00000000, const nsID & 
{...}, void * * 0x0403a500) line 1196
nsComponentManager::CreateInstance(const char * 0x0095f574, nsISupports * 
0x00000000, const nsID & {...}, void * * 0x0403a500) line 94
nsStreamConverter::Init(nsStreamConverter * const 0x0403a4e0, nsIURI * 
0x041ce404, nsIStreamListener * 0x041b42b4, nsIChannel * 0x041cfb04) line 500 + 
57 bytes
nsStreamConverter::AsyncConvertData(nsStreamConverter * const 0x0403a4e0, const 
unsigned short * 0x0095f89c, const unsigned short * 0x0095f800, 
nsIStreamListener * 0x041b42b4, nsISupports * 0x041cfb04) line 907 + 34 bytes
nsStreamConverterService::AsyncConvertData(nsStreamConverterService * const 
0x03818b70, const unsigned short * 0x0095f89c, const unsigned short * 
0x0095f800, nsIStreamListener * 0x041b42b4, nsISupports * 0x041cfb04, 
nsIStreamListener * * 0x041cf930) line 688 + 51 bytes
nsDocumentOpenInfo::RetargetOutput(nsIChannel * 0x041cfb04, const char * 
0x041d7550, const char * 0x041d7510, nsIStreamListener * 0x041b42b4) line 444 + 
102 bytes
nsDocumentOpenInfo::DispatchContent(nsIChannel * 0x041cfb04, nsISupports * 
0x00000000) line 406 + 44 bytes
nsDocumentOpenInfo::OnStartRequest(nsDocumentOpenInfo * const 0x041cf920, 
nsIChannel * 0x041cfb04, nsISupports * 0x00000000) line 253 + 16 bytes
nsMsgProtocol::OnStartRequest(nsMsgProtocol * const 0x041cfb00, nsIChannel * 
0x041cf6d0, nsISupports * 0x041ce400) line 202 + 66 bytes
nsMailboxProtocol::OnStartRequest(nsMailboxProtocol * const 0x041cfb00, 
nsIChannel * 0x041cf6d0, nsISupports * 0x041ce400) line 136
nsFileChannel::OnStartRequest(nsFileChannel * const 0x041cf6d4, nsIChannel * 
0x041cf250, nsISupports * 0x041ce400) line 444
nsOnStartRequestEvent::HandleEvent(nsOnStartRequestEvent * const 0x04188410) 
line 199
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x041a77a0) line 97 + 12 bytes
PL_HandleEvent(PLEvent * 0x041a77a0) line 563 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0197ec50) line 508 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00000b78, unsigned int 55534, unsigned int 0, 
long 26733648) line 1018 + 9 bytes
KERNEL32! bff7363b()
KERNEL32! bff94407()
00958b82()

Comment 1

19 years ago
crashed too, using 2000-03-26-08
on win 2000

Comment 2

19 years ago
cc: rhp.

mielke - is this with all messages?  Or a particular msg?
(Reporter)

Comment 3

19 years ago
With all messages also news.

I am pretty shure that this is a smoketest blocker

Comment 4

19 years ago
Yes, this was a screw up that has been fixed:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&r
oot=/cvsroot&subdir=mozilla/mailnews/mime/emitters/src&command=DIFF_FRAMESET&ro
ot=/cvsroot&file=nsMimeBaseEmitter.cpp&rev1=1.29&rev2=1.30

- rhp
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
*** Bug 33398 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
Adding crash keyword
Keywords: crash

Comment 7

18 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.