[CBX]partially obscured drop-down listbox looks weird when clicked on

REOPENED
Unassigned

Status

()

--
minor
REOPENED
19 years ago
9 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Steps to reproduce:
1. Scroll within http://bugzilla.mozilla.org/query.cgi so that a drop-down
listbox is halfway off of the page (at the top or bottom).
2. Click on the listbox.

Result: Dropdown part of box shows up, sometimes outside of the window, but the
"current selection" part of the box doesn't come up on top of the scrollbar or
whatever is blocking its view.
Expected: As long as it wouldn't require drawing something off of the screen,
mozilla should draw the "current selection" part of the listbox when the
dropdown is created, and allow it to be covered back up when it is closed.

Reproducable on MSIE as well.

Comment 1

19 years ago
The current behaviour of the listbox (html:select) widget matches the behaviour
of the IE5 controls on win32 (both in XUL and in HTML). However, the native 
MacOS and Motif widgets used in Nav4 do have a nicer implementation -- the menu
"pops up" above the surrounding chrome so that the listbox is one contiguous
panel. 

I'll attach two screenshots: 
1) listbox in XUL and HTML, using moz 2000032609 on win32, where the listbox
   is partially cut off by the bottom chrome of the containing window.
2) the same situation in HTML, but showing Motif widget in Nav4.x (MacOS widget
   works roughly the same way). 

(This is a bit of fine-tuning though, and I'm not suggesting that this is 
 a requirement -- but it's a nice idea for someday ...)

Comment 2

19 years ago
Created attachment 6956 [details]
screenshot; HTML & XUL listbox clipped by bordering chrome

Comment 3

19 years ago
Created attachment 6958 [details]
screenshot; native Motif widget in the same HTML situation
(Reporter)

Comment 4

19 years ago
Minor points:

The item should show up when you click on it no matter what would be drawn on 
top of (it sounded like you were saying it would only happen if mozilla chorme 
would be covered).

From the screenshot, it looks like MacOS covers the currently selected item in 
dropdowns, whereas Win32 avoids covering it.

Comment 5

19 years ago
changing component to html form controls, reassigning.  We're replacing the XUL
case with XBL listboxes, and use of HTML in XUL will be deprecated, so you may
get away without fixing that part.
Assignee: trudelle → rods
Component: XP Toolkit/Widgets → HTML Form Controls
QA Contact: jrgm → ckritzer

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → LATER

Comment 6

19 years ago
Right or wrong, Windows behaves just like the first screen shot. I am not sure 
about the Motif screen shot, it looks like they are still using the native 
widgets.

This is a known problem and dup of a bug I clsed out long time ago. I will mark 
this "later" because it would be nice to fix. but it is way down on the list.

Comment 7

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Comment 8

18 years ago
reopening and marking Future...
Status: RESOLVED → REOPENED
Resolution: LATER → ---
Target Milestone: --- → Future

Updated

18 years ago
Status: REOPENED → ASSIGNED
Summary: partially obscured drop-down listbox looks weird when clicked on → [CBX]partially obscured drop-down listbox looks weird when clicked on

Comment 9

18 years ago
I am marking this won't fix, because I am not going to fix this now and 
eventually we will move over to XBL-Widgets
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → WONTFIX

Comment 10

17 years ago
this still exists
reopening ... based on  Comments From rods@netscape.com 2000-04-02 06:48
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

17 years ago
Priority: P3 → --
Assignee: rods → nobody
QA Contact: bsharma → layout.form-controls
You need to log in before you can comment on or make changes to this bug.