Firefox no longer works after automatic update to 1.5.0.2

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Stu Collett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I was just browsing away as normal and I got an "update now" message from mozilla asking me to allow it to automatically update. As I've done this in the past with no issues I was happy to oblige. It went through the motions, closing my browser window and running the setup and eventually opened up a new firefox browser with the annoying message : 

Unable to connect 
Firefox can't establish a connection to the server at www.mozilla.org 

...as if i no longer had an internet connection. So I thought "oh ok, my connection must have dropped"...so I stopped and restarted my connection and tried the browser again...same message. A little worried now I thought I'd try a common site, only to get the message : 

Unable to connect 
Firefox can't establish a connection to the server at www.google.com 

In the vain hope that I was still having connection issues I decided to open up IE....which turned out to work just fine, hence why I can type this post. 

I've restarted my machine twice since and it still comes up with the same "unable to connect" errors with a variety of different websites.  Something happened when the browser was updated but I don't know what!  Please help, I really don't want to be forced to have to go back to using IE!!

Reproducible: Always

Steps to Reproduce:
1. Open Browser
2.
3.

Actual Results:  
I always keep my browser up-to-date, so I would say that it is safe to say I was updating from the latest version before 1.5.0.2.  All I did was click "yes" when asked if i wanted to restart my browser with the latest update.

Expected Results:  
It should have just carried on as normal, but instead it doesn't allow me to view any websites at all.

Here is my BuildConfig in case it helps...

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-official-branding --enable-svg --enable-canvas --enable-update-packaging
See http://kb.mozillazine.org/Error_loading_any_website
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 2

12 years ago
I am experiencing a similar problem; post update Firefox completely dies. Re-installed, wiped all files etc, still the same problem. Something appears seriously wrong with the update, and we are not alone -see comments here.

http://mozillazine.org/talkback.html?article=8220

Any ideas as to a fix are badly needed.
Status: RESOLVED → VERIFIED

Updated

12 years ago
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

12 years ago
I deleted all traces of mozilla/firefox from my ZoneAlarm firewall exceptions and then re-initiated the windows firewall...i found that after *another* restart that my firewalls re-asked me for approval to let firefox access the internet.  After I accepted, everything was back to normal and working fine. I tried this method after reading the link that was originally posted by Ryan Flint as a solution.

Although a rough fix, I find this unacceptable - I am a web designer by trade and regularly recommend firefox as an "easier browser to use".  This bug could set firefox back by years as I can guarantee that *none* of my clients will go to the same trouble that I did and will happily revert back to IE. Shame.

Comment 4

12 years ago
This is not a bug in Firefox, it's a bug in ZoneAlarm, which failed to prompt you asking to give Fx 1.5.0.2 permission to access the Internet. This should be marked INVALID.
(In reply to comment #2)
> I am experiencing a similar problem; post update Firefox completely dies.
> Re-installed, wiped all files etc, still the same problem. Something appears
> seriously wrong with the update, and we are not alone -see comments here.
> 
> http://mozillazine.org/talkback.html?article=8220
> 
> Any ideas as to a fix are badly needed.
> 

Mozilla already sends hashes of new releases to the major firewall manufacturers and updated rule sets from those manufacturers are released well in advance of a new Firefox release. Actually getting users to grab the new rule sets is most certainly not a Firefox issue. We already throw up a page when we're unable to connect indicating that a poorly configured firewall may be to blame.

If you want to discuss this issue, add a comment to this blog entry: http://www.beltzner.ca/mike/archives/2006/04/14/firewalled_1502.html
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID

Comment 6

12 years ago
(In reply to comment #5)
> (In reply to comment #2)
> > I am experiencing a similar problem; post update Firefox completely dies.
> > Re-installed, wiped all files etc, still the same problem. Something appears
> > seriously wrong with the update, and we are not alone -see comments here.
> > 
> > http://mozillazine.org/talkback.html?article=8220
> > 
> > Any ideas as to a fix are badly needed.
> > 
> 
> Mozilla already sends hashes of new releases to the major firewall
> manufacturers and updated rule sets from those manufacturers are released well
> in advance of a new Firefox release. Actually getting users to grab the new
> rule sets is most certainly not a Firefox issue. We already throw up a page
> when we're unable to connect indicating that a poorly configured firewall may
> be to blame.
> 
> If you want to discuss this issue, add a comment to this blog entry:
> http://www.beltzner.ca/mike/archives/2006/04/14/firewalled_1502.html
> 
Just to be very clear, I'm not running Zone Alarm; Windows firewall is disabled. This bug isn't resolved!

Comment 7

12 years ago
Is this a duplicate of Bugzilla Bug 270084
end of the installation should contain a message that reminds people to configure their firewalls?

Comment 8

12 years ago
(In reply to comment #5)

> Just to be very clear, I'm not running Zone Alarm; Windows firewall is
> disabled. This bug isn't resolved!

Were you running ZoneAlarm previously? I just ran into this problem and fixed it very quickly. My situation: I had ZoneAlarm installed, but not running (I had disabled its startup piece). However, the "Windows Security Alerts" taskbar icon was still informing me that ZoneAlarm was On. So I think it was still functioning somewhat, enough to block the new FF version. Solution was to start ZoneAlarm and manually add the new FF to the allowed to access internet list.

Now I'm going to uninstall ZA for real and save myself this trouble in the future.

Comment 9

12 years ago
I'm surprised that Zonealarm caused this. Any good firewall should do a CRC check of the executable, and pop up an alert for that executable saying "new program" or something to that effect.

This should be cross-posted on the Zonealarm forum.

--Sam

Comment 10

12 years ago
(In reply to comment #9)
> I'm surprised that Zonealarm caused this. Any good firewall should do a CRC
> check of the executable, and pop up an alert for that executable saying "new
> program" or something to that effect.
> 
> This should be cross-posted on the Zonealarm forum.
> 
> --Sam
> 

I'm no longer a ZA user, but I recall that it can be configured to deny Internet access to unreconized executables rather than prompting for input. In any case, the issue is with ZoneAlarm and not Fx.

Comment 11

12 years ago
I now have four instances of firefox.exe running in the background although firefox isn't actually open. I can see them in the taskmanager, though when I click to close them, nothing happens. Nothing. Each one of these four instances of firefox was also caused by me trying to access the internet. It didn't work and the program didn't even show that it was "unable to connect." It just stopped. I have to restart the computer to do anything with firefox, even something as simple as uninstalling it. I thought something was interfering with firefox, like the fact that plug-in extensions wouldn't update the first time I installed firefox 1.5.0.2 (1.5.0.1 on the first try). So I tried everything --- I looked at my firewall program (Norton) to see if it was blocking anything, I looked at adwatch to see if it was preventing registry keys from being installed, and both were fine. My security programs weren't messing with firefox. So I unistalled firefox, got rid of the data it leaves on your computer, and the registry keys, and even the installer, and restarted. Then I tried reinstalling firefox and it still didn't work. I've been doing a lot of troubleshooting here and I still can't get it to work right. I hate IE, but I'm out of ideas. Is there any way to fix firefox?

Comment 12

12 years ago
I can confirm this bug as well.

My girlfriends laptop suddenly is unable to connect to the internet via firefox since the 15.0.2 update as well.  IE and Opera work fine though.

Moreover, the HTML validator extension (on my work computer) was complaining that the HTML Cache was turned off after the upgrade.  Sure enough, I looked in about:config and it was off (not my doing).

Neither computers use zonealarm (never used it ever).

Is this bug really resolved invalid?
*** Bug 335955 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.