Wetter.com pages often fail to finish loading with HTTP Pipelining enabled

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: Greg K., Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pipelining], URL)

(Reporter)

Description

12 years ago
With HTTP Pipelining enabled, this and other Wetter.com pages often never finish loading.

With pipelining enabled: page load failed to complete 4 out of 5 times
Without pipelining:      page load completed 5 out of 5 times.

This is a long-time problem, but I can currently reproduce using FF 1.5 on Win and Mac, as well as Camino.
(Reporter)

Updated

12 years ago
Whiteboard: [pipelining]
(Reporter)

Comment 1

12 years ago
Netcraft shows the server running Apache/1.3.27 Unix Red-Hat/Linux PHP/4.1.2, possibly behind a NetCache appliance NetApp/6.0.2P1D1.

Comment 2

12 years ago
Now the web site is using Apache/2.0.52 (Red Hat) PHP/4.3.9, of course it is lagging behind with the software upgrades.
I think that the problem is on netcache side (99.99%), so Greg, please, tell the web sysadmin to upgrade again Apache (i.e. to 2.0.57 or to the upcoming 2.0.58) and then, without any doubt, the netcache appliance.
(Reporter)

Comment 3

12 years ago
That's unlikely to happen. Do you know some specific reason .52 would be an issue here? Or, the netcache? Enlighten us.
(Reporter)

Comment 4

12 years ago
It may not be Wetter.com's fault, after all. I noticed that when page load stalls, the Status Bar usually shows another domain as "Loading", currently www.billiger.de as of today.

Comment 5

12 years ago
(In reply to comment #4)
> It may not be Wetter.com's fault, after all. I noticed that when page load
> stalls, the Status Bar usually shows another domain as "Loading", currently
> www.billiger.de as of today.

interesting that I don't have a problem with SM

FF fails ~50% (shows loading 20-30sec) of time. I'm not seeing www.billiger.de
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060612 Minefield/3.0a1

Comment 6

11 years ago
(In reply to comment #5)
> 
> interesting that I don't have a problem with SM

Me too, no problem even with Mozilla 1.7.13 + patched nsHttpTransaction.cpp.

> FF fails ~50% (shows loading 20-30sec) of time. I'm not seeing www.billiger.de
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060612
> Minefield/3.0a1

Does FF fail on pages with flash or shockwave plugins ?

Comment 7

7 years ago
I can't reproduce this on Windows or Linux FF 3.6.8.  I'm guessing that wetter.com no longer uses NetCache.  Netcraft currently says OS: Linux and Server: WEB01/WEB02-06.  NetCraft does still detect NetCache NetApp/6.0.5 for nokia.com, and I don't experience any problems on that domain.
http://uptime.netcraft.com/up/graph/?host=www.nokia.com

Comment 8

7 years ago
WFM then. If that's not the most appropriate resolution, please change.
Thanks for the test
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.