No support for indic scripts on Mac (Devanagari/Gujarati) ?

RESOLVED DUPLICATE of bug 205476

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 205476
12 years ago
12 years ago

People

(Reporter: Rotis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

http://hi.wikipedia.org/wiki/

All Hindi text is written as question marks (?????). Firefox (Mac) seems not to support indic scripts. The fun thing is, the Firefox window does support it. See the title, there are the right characters, probably put there by the operating system. Screenshot here: http://i2.tinypic.com/vgsaio.jpg

The same problem on the BBC Hindi page, millions of question marks: http://www.bbc.co.uk/hindi/

This Indian page (http://www.sandesh.com/) shows no indic letters, no question marks, but lots of stange symbols. See screenshot: http://i2.tinypic.com/vgsavc.jpg

Configuration: Firefox 1.5.0.2 on Mac OS X 10.4.6

Other browsers like Safari, Shiira or iCab do display the indic scripts.

Reproducible: Always



Expected Results:  
Display of indic scripts.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 205476 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
OS: Mac OS X 10.2 → Mac OS X 10.4
(Reporter)

Comment 2

12 years ago
Meanwhile I found a workaround. Obviously FF/Moz/Gecko cannot handle the factory-installed Devanagari/Hindi/Gujarati fonts on MacOSX. Solution: Install the OpenSource-fonts "FreeSans" and "FreeSerif". Now MacOSX 10.4 displays Indic scripts perfectly.

I had the same questionmark problem with Armenian on MacOSX in FF/Moz/Gecko (but I don't know, if MacOSX supports this script from factory). I installed the font "Arial Unicode MS" which ships with several Windows applications. Now Armenian runs flawlessly too.

I hope this may help some people with font problems.
You need to log in before you can comment on or make changes to this bug.