Closed Bug 33407 Opened 20 years ago Closed 20 years ago

HTML Anchor element. CSS Margin values is applied only to the first line.

Categories

(Core :: Layout, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED INVALID

People

(Reporter: scott.r.vesey, Assigned: rickg)

References

()

Details

(Keywords: verifyme)

Attachments

(1 file)

When a margin value is applied to an Anchor element the margin is only applied 
to the first line when the anchor element wraps to a second line.

Since an Anchor tag is not a block element it is not clear that the margin value 
should be applied at all.  If the value is applied, it should be applied to all 
lines contained in the element.
Attaching testcase, confirming.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
The problem has nothing to do with margins. The problem is that you have a <p> 
tag inside an anchor <a>, which is not legal (strictly speaking). The residual 
style handling code is going through 1 more revision which will allow this 
(illegal) but backward compatible idiom.
Status: NEW → ASSIGNED
Bad HTML --> a workaround exists: fix the HTML! --> low priority unless shown to 
be widespread on web. Can anyone find examples on Web, esp. within Top 100? 
Marking M19; --> FUTURE if not common. (Unless rickg just fixes it. ;-> )
Target Milestone: --- → M19
Rick: I don't see any paragraphs inside an <a> tag in the test case.

The test case is invalid, however, as the assertion given is incorrect per CSS1.
Margins on inline elements must only apply on the first line.

Marking INVALID.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Keywords: verifyme
Resolution: --- → INVALID
massive update for QA contact.
QA Contact: petersen → lorca
Sounds good to me.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.