Real plugin doesn't register for audio/x-pn-realaudio

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Plugins
RESOLVED INVALID
12 years ago
2 years ago

People

(Reporter: Deb, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

Plugin finder for RealPlayer tries to re-install all of Real Player.  Even when I do RE-install the already existing version of Real Player (Real Player 10-5Gold) FireFox still says the plugin is not found.

Reproducible: Always

Steps to Reproduce:
1. visit http://imdb.com/title/tt0425210/trailers
2. select one of the RealTime trailers
3. The plugin finder says it is not found.

Actual Results:  
get the message to "Install Missing Plugins" and a box to start the download

Expected Results:  
should play the trailer

You guys seem to have the same set of problems at every release.  It makes me think I should go back to brand-x browser.

1. Create an architecture for extentions/plugins so that the interfaces don't change at every release

2. Publish and stick to that architecture so that a release upgrade does NOT mean all of the incidental bits stop working

3. Do more and better testing.  No one bothered to test imbedded RealPlayer? I see that at least on past release you have had trouble with Adobe documents, quicktime, and a host of other plugins.  What do you think people do on the web? Read each others C++ code?

Comment 1

12 years ago
cc: jst

The problem here is that the website is using the audio/x-pn-realaudio mimetype, yet the Real plugin does not register for that mimetype.  However, the PFS does return Real for that plugin.

To me it looks like Real should register for audio/x-pn-realaudio, since IE does end up using Real.

So either we fix the PFS backend to not send back the Real plugin, or ask Real to change their plugin to register for audio/x-pn-realaudio.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: http://imdb.com/title/tt0425210/trailers-screenplay-E26811-6-3 → Real plugin doesn't register for audio/x-pn-realaudio
Duplicate of this bug: 362569
Duplicate of this bug: 326202
Duplicate of this bug: 339826

Updated

11 years ago
Component: Plugin Finder Service → Plugins
Product: Firefox → addons.mozilla.org
QA Contact: plugin.finder → plugin-listings
INVALID, though really a candidate for 3RDPARTY resolution: this is a problem with the Real plugin (or was, not sure if it still exists).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.