Scroll bar of element behind shows through elements stacked on top.

RESOLVED DUPLICATE of bug 187435

Status

()

RESOLVED DUPLICATE of bug 187435
13 years ago
13 years ago

People

(Reporter: petermichaux, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

Element A has scroll bars.

Element B is stacked on top of element A.

The scroll bars of element A show through the background of element B

Here is the example. You can remove the "z-index" and the results are equally bad.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">

<html lang="en">
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	<title>untitled</title>

</head>
<body style="margin:0;padding:0;">

<div style="overflow:scroll;z-index:1;">
  hi
</div>
<div style="position:absolute;top:0;left:0;background:green;height:50px;z-index:3;">
  good bye
</div>
</body>
</html>


Reproducible: Always

Steps to Reproduce:
1.run the examples
2.
3.

Actual Results:  
the scroll bar shows through from behind

Expected Results:  
the scroll bar in the element behind should be hidden by the green element on top.

Comment 1

13 years ago
Duplicate of bug 330090 -> Core bug 187435.

*** This bug has been marked as a duplicate of 187435 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.