If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Autocomplete overrides values given in html-source in input-tag

RESOLVED DUPLICATE of bug 270558

Status

()

Firefox
Address Bar
--
minor
RESOLVED DUPLICATE of bug 270558
12 years ago
12 years ago

People

(Reporter: Jammni, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

Make a form with a normal input-tag and a input-tag with password type.
Fill out the fields and save the information when firefox asks you to do so.
If in the source a value attribute is specified, firefox overrides these values with the auto-complete values.
But it shall not override these values.

Reproducible: Always

Steps to Reproduce:
1. Make a form with input-tag and input-tag with password type.
2. Specify the value attribute for at least one of the tags.
3. Fill out the form and submit it.
4. Reload the page - autocomplete overrides the values given from source.
Actual Results:  
Firefox overrides the values given in the source with the autocomplete values.

Expected Results:  
Firefox shouldn't override the source-values. Autocomplete should only apply to form-elements, that have no value (or perhaps an empty value). The user has at all time the possibility to autocomplete the fields with a double click on the input-field.
Should be fixed in Firefox 2.0

*** This bug has been marked as a duplicate of 270558 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.