Erroneous search matching @ koders.com

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Patrick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

At koders.com, when you view source, on the left side there are line numbers. Try searching for '11' on a source page (say the link above). When you get to a line number that ends with '1', and on the next line starts with '1', a match is made. However, it really shouldn't be, because there is more text on the right hand side.

Looking at the page source, the problem seems to be that Firefox reads the table code as one (just as it's in the page source); for example, the line-showing code looks like this:

<code>&lt;a href="#L111" name="L111"&gt;111&lt;/a&gt;&lt;br/&gt;&lt;a href="#L112" name="L112"&gt;112&lt;/a&gt;&lt;br/&gt;...</code>

So, of course, to FF, this looks like that's how the page is set up... with numbers showing continually from left to right (though there are br's there). However, it's one per line.

Reproducible: Always
Component: Search → General
QA Contact: search → general
The numbers down the left side are just one big div, with <pre> and <br/>s seperating the number. I guess this is the same as bug 139225?
Assignee: nobody → general
Component: General → General
Product: Firefox → Mozilla Application Suite
QA Contact: general → general
(this component sucks, but apparently it's where find bugs go for lack of it's own component)
Assignee: general → guifeatures
Component: General → XP Apps: GUI Features
OS: Windows XP → All
QA Contact: general
Hardware: PC → All

Comment 3

10 years ago
Mozilla/5.0 (X11; U; Linux i686; rv:1.9b5pre) Gecko/2008032501 SeaMonkey/2.0a1pre
Behavior exist, but its logical for me, find should find in text, not in metadata. Resolving as WFW, reopen if not agree 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.