Redraw problems in Cookie Manager

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
normal
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: Richard Ekle, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Bring up the cookie manager.  The first tab "Stored Cookies" is highlighted in
bold text.  Move the mouse over one of the other tabs and click on it.  It
switches to the second tab and highlights the second tab in bold text.  The
problem is the first tab is still highlighted in bold text.  If you move the
mouse over the first tab it gets unhighlighted, but it should unhighlight as
soon as you click on the other tab.

Comment 1

18 years ago
I'm guessing the tabs are done with XUL so changing component and reassigning
Assignee: troy → trudelle
Component: Layout → XP Toolkit/Widgets: XUL
QA Contact: petersen → jrgm

Comment 2

18 years ago
Created attachment 7024 [details]
simplified tabcontrol; font-weight: not reverted when 'selected' changes

Comment 3

18 years ago
The style for the text in the <tab> is not updated when the value of 
selected changes from 'true'.
(Assignee)

Comment 4

18 years ago
I can't reproduce this on Win98 using today's verification builds; is it
specific to NT or debug builds?

Comment 5

18 years ago
I can't reproduce it in 20000330nn builds for mac, linux and win98. 
resolving as worksforme.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101014 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.