Closed Bug 334473 Opened 14 years ago Closed 14 years ago

Files not opened, because a wrong URL appears in the address bar when double-clicking a file that is inside a folder with non-english characters

Categories

(Core Graveyard :: File Handling, defect)

1.8 Branch
x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 312287

People

(Reporter: moz, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060404 SeaMonkey/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060404 SeaMonkey/1.0.1

Category that probably this error belongs to:
      - "File Handling" category [I didn't find this category when reporting this bug]

Computers in which the error is seen:
      One computer with:
      - Seamonkey 1.0.1 [with the xpi of the Spanish language], clean installation.
      - windows 2000 in spanish.

      Another computer with:
      - Seamonkey 1.0.1 [with no xpi added], clean installation.
      - windows 2000 in spanish.

Circumstances when the error is seen:
      - You go into a folder with a non-English character, like "gestión" 
      - You double-click on a .html file inside the folder

Error effects:
      - Seamonkey fails when opening the file.
      - An error page is displayed [please see the screenshot, specially the difference between the address bar and the error page]

Comments about the seen error: 
      - An extra "25" is added inside the URL (!), next to the "escaped code".
      - The URL in the address bar (is wrong) is different to the error page one (this last is correct)

Extra comments:
      - If you drag and drop the file inside Seamonkey, it works flawlessly (the right URL appears in the address bar)
      - This error has been bugging people in Seamonkey 1.0.1, 1.0.0 and 1.0b at least. But not in Mozilla 1.7.X.

Reproducible: Always

Steps to Reproduce:
[At least in windows 2000 in Spanish]
1. Create a folder with a non-English character, like "gestión"
2. Put an .html file in the newly created folder
3. Double-click on the file

Actual Results:  
You get an error, like if the file did not exist (the URL seen in the address bar is wrong). 

Expected Results:  
The file should have been opened.

This is very irritant. Also we have to be careful when an Internet Explorer user is near so he does not see this!
Assignee: general → file-handling
Component: General → File Handling
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch
I suppose the extra "25" appear because Seamonkey is escaping the % as %25  (of course, it shouldn't try to escape it, as it is already a escaped code).

I've set the priority of this bug as "normal", though many people (as me) have a lot of documentation in html files under folders with non-english characters and for us is really annoying... there are also a lot of people who does not suffer because of this.

Last but not least, I have available some computers (two with Seamonkey 1.0.1 and others with Mozilla 1.7) so you can ask me to do the tryings you need.
Severity: major → normal
Does it happen with firefox 1.5.0.x?
Dup of bug 312287?
Indeed, it is.

*** This bug has been marked as a duplicate of 312287 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.