Closed Bug 334506 Opened 14 years ago Closed 14 years ago

Import cannot read exported ics file containing email alarms

Categories

(Calendar :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mozilla, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051104 Mozilla Sunbird/0.3a1

I exported an Event containing an email alarm. When importing it into the calender it says: "Error: [Exception... "Illegal value"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: file:///C:/Programme/Mozilla%20Sunbird/components/calStorageCalendar.js :: anonymous :: line 1631"  data: no] Source File: file:///C:/Programme/Mozilla%20Sunbird/components/calStorageCalendar.js
Line: 1631"

(No, it is not a duplicate entry, when I removed the 
X-EMAILADDRESS:herethe@email.address
line in the ics file it was imported succesfully)


Reproducible: Always

Steps to Reproduce:
1. Create an Event with an email alarm
2. Export the event to an ics file
3. Delete the event from the calendar
4. Try to import it from the ics file

Actual Results:  
Error message as stated in Details

Expected Results:  
Successfull import

Something seems wrong with the "X-EMAILADDRESS" flag.

Remark: I just used the current a1 release and not the nightly build, but could not find a similar bug that indicates it would works.
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060418 Mozilla Sunbird/0.3a1+.

The JavaScript Console reports:

    Error: flushItem DB error: not an error
    Source File: file:///D:/sunbird/components/calStorageCalendar.js
    Line: 1572
    -----------
    Error: [Exception... "Illegal value"  nsresult: 
            "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"]
    Source File: file:///D:/sunbird/components/calStorageCalendar.js
    Line: 1739
    -----------
    Error: Import error: [Exception... "Illegal value"  nsresult: 
           "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"]
    Source File: chrome://calendar/content/import-export.js
    Line: 184

If I open the ics file directly no error is displayed.

But Sunbird changes the line from
    X-EMAILADDRESS:xxx@yyyyyy.zzz
to
    X-EMAILADDRESS:[xpconnect wrapped calIIcalProperty]

Console displays the following error:
    XXX failed to set alarmEmailAddress to [xpconnect wrapped calIIcalProperty]:
    [Exception... "Component returned failure code: 0x80070057 
    (NS_ERROR_ILLEGAL_VALUE) [calIICSService.createIcalProperty]"  nsresult:
    "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: 
    file:///D:/sunbird/components/calEvent.js :: anonymous ::
    line 183"  data: no]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch patchSplinter Review
With this patch the email adress is preserved during import into storage calendar, open as ics calendar, editing event and exporting to ics file.
Attachment #218854 - Flags: first-review?(jminta)
Comment on attachment 218854 [details] [diff] [review]
patch

Nice catch.  r=jminta and I'm landing this for 0.3a2.
Attachment #218854 - Flags: first-review?(jminta) → first-review+
Patch checked in.  I'd love it if someone could confirm the fix in tomorrow's nightly, since 0.3a2 isn't too far off.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
I tried it in the current nightly (2006-04-23 14:30:00) and it was imported without any error. Also the export of this event still preserved the correct email address. (But in this build I can not specify the email address seperatly in the event dialog, so I am not sure about using this flag later on.)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.