Closed Bug 334638 Opened 15 years ago Closed 15 years ago

Snooze button not working on reminder popup

Categories

(Calendar :: Sunbird Only, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 298358

People

(Reporter: nroberge, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When I get a popup reminding me of an appointment, the dismiss button doesn't perform any action.

Reproducible: Always

Steps to Reproduce:
1. Fix an appointment with a reminder before X minutes
2. The popup opens before the event
3. Click Dismiss

Actual Results:  
Nothing.

Expected Results:  
The popup closes.
Are there any errors in the javascript console when this happens?
It was the snooze button and not the dismiss. My mistake. I don't see a error message. Where is this javascript console located?
Summary: Dismiss button not working on reminder popup → Snooze button not working on reminder popup
I found the javascript console. Here are the two messages that appear:

Error: [Exception... "Could not convert JavaScript argument arg 0 [calIDateTime.addDuration]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calAlarmService.js :: anonymous :: line 195"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calAlarmService.js
Line: 195

Error: [Exception... "Could not convert JavaScript argument arg 0 [calIDateTime.addDuration]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calAlarmService.js :: anonymous :: line 195"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calAlarmService.js
Line: 195
The errors described were fixed in bug 315051, and the snooze button was hidden there.  It's going to be brought back in bug 298358.  Please be sure to test with nightly builds before filing bugs, as many things can change there from the last release version.

*** This bug has been marked as a duplicate of 298358 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.