can't select < or > in view source window (generated content)

VERIFIED FIXED in Future

Status

()

Core
Layout
P2
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Warren Harris, Assigned: mjudge)

Tracking

({helpwanted})

Trunk
Future
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

19 years ago
Bring up a web page and do view source. (e.g. abcnews.com) You'll see something 
like:

<html>
<head>
<meta NAME="Pragma" CONTENT=...>

If you put your cursor before the first < and drag forward, you can only select 
the < character. If you put it after the < and drag forward, it will select the 
words "html" "head" "meta" etc. but none of the < or > characters.

If you double-click on NAME, above, it will highlight NAME and "Pragma" but not 
the = between them. It should only highlight/select NAME.

Copying text doesn't seem to work either.
(Reporter)

Comment 1

19 years ago
I also noticed that if you select and drag down to the bottom of the page, the 
page won't automatically scroll to let you select more than is currently 
visible. 

Also if you click and drag down off the bottom edge of the window and let go of 
the mouse button, and then move back into the window, the highlight will 
continue to track the mouse position. It appears to be missing the mouse-release 
event.

Comment 2

19 years ago
off to mike judge, who I believe is doing selection and usability issues.
Assignee: rickg → mjudge

Comment 3

19 years ago
I think Mike is planning to enable this for M15 (selection of generated content)
OS: Windows NT → All
Priority: P3 → P2
Hardware: PC → All
Summary: can't select < or > in view source window → can't select < or > in view source window (generated content)
Target Milestone: --- → M15
(Assignee)

Comment 4

19 years ago
fixed. this was harder than you would think.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
Warren,

This looks fixed in the May 22nd build. Could you take a quick look please ?
(Reporter)

Comment 6

18 years ago
Technically, what I've reported is fixed, but now there are a slew of other 
selection bugs:

1. Select a range of text ( < and > characters select ok) but then click 
somewhere to the right of any of the selected characters in the whitespace. 
Nothing gets unselected. This should unselect the current selection and move the 
insertion point to the end of the line that you've clicked to the right of.

2. Start a selection by clicking in white space and dragging onto some text. The 
selection start point starts from where it thought the insertion point 
previously was, not from where you clicked.

3. Double click a word. What gets selected is any whitespace-delimited text, not 
a word. E.g. "NOWRAP><A=" rather than just "NOWRAP".

Needless to say, this is horribly broken.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

18 years ago
Mass moving old milestone bugs to M16
Target Milestone: M15 → M16

Comment 8

18 years ago
generated content issues will be dealt with in a later milestone release
Target Milestone: M16 → M18
Painful though it is, this should be considered for FUTUREing as there's a 
workaround: Save As and then open the file in a text editor. eng call based on 
LOE.

Comment 10

18 years ago
*** Bug 42701 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
*** Bug 36408 has been marked as a duplicate of this bug. ***
See also bug 12460. DUP?
(Assignee)

Comment 13

18 years ago
selection should be fixed here but the real problem is not being able to copy 
the selected text at all! marking this bug dependent on 13068. 
Status: REOPENED → ASSIGNED
Depends on: 13068
Keywords: correctness, nsbeta3

Comment 14

18 years ago
setting to nsbeta3+
Whiteboard: nsbeta3+

Comment 15

18 years ago
adding the brackets in the status
Whiteboard: nsbeta3+ → [nsbeta3+]

Comment 16

18 years ago
*** Bug 47375 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
*** Bug 47373 has been marked as a duplicate of this bug. ***
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED
oops
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 20

18 years ago
not sure what happened with this one. whacking the mole again.
Status: REOPENED → ASSIGNED
Target Milestone: M18 → Future

Comment 21

18 years ago
I'm able to select the < & > within view source -- can't do anything with them, 
but they are selectable, so that part is actually resolved -- right? Not being 
able to copy/paste should be another bug.
Keywords: helpwanted
(Reporter)

Comment 22

18 years ago
The point of this bug was that you not only wanted to be able to select these 
things, but you want to copy them and paste them elsewhere. Select w/o copy is 
useless -- I think you should not open a separate bug for that.

Comment 23

18 years ago
sorry, the summary of this bug is that you can't select, which is much different 
than not being able to copy/paste. The ability to copy/paste is beyond our scope 
and a new bug was submitted and assigned to vidur to rewrite the methodology for 
displaying the data -- either plaintext or html. Once that issue is resolved 
then being able to select consistently will also be resolved.
(Reporter)

Comment 24

18 years ago
Sorry, when I wrote the bug up, I meant select & copy.

Comment 25

18 years ago
ok, since you can select the generated content, this is fixed, the copy paste 
part is in another bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 26

18 years ago
What's the other bug?

Comment 27

18 years ago
49187 -- ViewSource must be plaintext or html

Comment 28

18 years ago
Fixed in the Aug 24th build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.