<select size="1"> appears as a listbox instead of a combobox for me

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: francisco.cavaco, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

not really sure what caused it - had the update for the latest version and installed the javascript debugger extension before it started happening.
A colleague of mine has the exact same version of firefox and doesn't have the problem.


Reproducible: Always

Comment 1

13 years ago
If you select the dropdown, right-click, and select "View Selection Source", what do you see for the <select> element?  I see

<select name="Epson_ProductRangeList" size="1" onchange="Epson_FillProductList(this.options[this.selectedIndex].value,null);Epson_isValid('Epson_PRMissing');Epson_ClearBox();" language="javascript" id="Epson_ProductRangeList" class="DropDownMenu">

(Btw, the <select> on this page seems to be created by JavaScript.  If I turn off JavaScript, it doesn't appear at all.)

If you load
data:text/html,<select size="1"><option>A</option><option>B</option></select>
do you get a dropdown or a listbox?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> If you select the dropdown, right-click, and select "View Selection Source",
> what do you see for the <select> element?  I see
> 
> <select name="Epson_ProductRangeList" size="1"
> onchange="Epson_FillProductList(this.options[this.selectedIndex].value,null);Epson_isValid('Epson_PRMissing');Epson_ClearBox();"
> language="javascript" id="Epson_ProductRangeList" class="DropDownMenu">
> 
> (Btw, the <select> on this page seems to be created by JavaScript.  If I turn
> off JavaScript, it doesn't appear at all.)
> 
> If you load
> data:text/html,<select size="1"><option>A</option><option>B</option></select>
> do you get a dropdown or a listbox?
> 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
	<head>
		<title>Enter the title of your XHTML document here</title>
	</head>
	<body>
		<div>
		<select size="1"><option>A</option><option>B</option></select>

		</div>
	</body>
</html>

Hi Jesse, thanks for the quick repply,

For the xhtml above I get a list.

And I can see the same exact same source as you do.
The hint on the javascript kind of make sense due to having installed the Javascript debuger some time before I've lost the combos.

Comment 3

13 years ago
If you're getting the wrong kind of control for that simple XHTML testcase, the problem probably isn't related to the JavaScript Debugger.
(Reporter)

Comment 4

13 years ago
makes sense.

Comment 5

13 years ago
Does running Firefox in safe mode (to temporarily disable all your extensions) help?  See http://kb.mozillazine.org/Safe_Mode.
(Reporter)

Comment 6

13 years ago
no. Still the same problem.

Comment 7

13 years ago
Odd.
Component: General → Layout: Form Controls
Product: Firefox → Core
QA Contact: general → layout.form-controls
Summary: the select tag doesn't render properly on my browser. It cames out as a list of options rather than a combo box → <select size="1"> appears as a listbox instead of a combobox for me
Version: unspecified → 1.8 Branch
(Reporter)

Comment 8

13 years ago
the only thing I can think is to reinstall firefox ??!!

is there anyway I can reset the about:config settings?

Comment 9

13 years ago
You can create a new profile for testing: http://kb.mozillazine.org/Profile_Manager.
(Reporter)

Comment 10

13 years ago
It does work with the new profile.

Is there anyway I can reset the settings of the old but still keep my extensions and tools?

Comment 11

13 years ago
I don't know an easy way.  You can copy your bookmarks and maybe your extensions from your old profile to your new profile manually.

It would be great if you could identify which file in your old profile caused this problem.  If it's a file you can upload without giving away sensitive information (e.g. passwords), we could use it to figure out what the bug in Firefox is and fix it.
Francisco, can you still reproduce this bug?  do you have the "prefs.js"
file from the profile where the problem occurred?
Francisco, can you still reproduce this bug?  do you have the "prefs.js"
file from the profile where the problem occurred?
If so, please reopen the bug.

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.