Closed Bug 334727 Opened 14 years ago Closed 14 years ago

Problem with opening saved pages with cyrillic filenames

Categories

(Core Graveyard :: File Handling, defect)

1.8 Branch
x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 312287

People

(Reporter: pppx, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060404 SeaMonkey/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060404 SeaMonkey/1.0.1

When I open saved page with cyrillic name, I get the "File Not Found" error. The link to file in URL box is incorrect - instead of 
"file:///m:/Pers/text/%DD%EB%E5%EA%F2%F0%E8%F7%EA%E8/%CA%E8%E5%E2-%D4%E0%F1%F2%EE%E2.htm"
it uses
"file:///m:/Pers/text/%25DD%25EB%25E5%25EA%25F2%25F0%25E8%25F7%25EA%25E8/%25CA%25E8%25E5%25E2-%25D4%25E0%25F1%25F2%25EE%25E2.htm"
Bug doesn't appear when i first time start Seamonkey, or if "Download manager" open with no Navigator windows.

Reproducible: Always

Steps to Reproduce:
1.Open any page in internet
2.Save it with cyrillic filename, for expample "Название на русском" or "Назва українською"
3.Try to open saved page, you get the "File not found" error, if there is open one or more Navigator windows

Actual Results:  
Get "File not found" error

Expected Results:  
Open saved page

Bug exists on Seamonkey 1.0/1.0.1
Seamonkey 1.0b works fine
No additional plugins, except flash plugin, does not intalled. Theme - modern.
Version: unspecified → Other Branch
Assignee: general → file-handling
Component: General → File Handling
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Version: Other Branch → 1.8 Branch
reporter, are you using Russian Windows? If you do, this is a dupe of bug 312287. Otherwise, this is a combination of bug 312287 and bugs 162361/278161 (and related bugs).
Yes, my main system is russian win2000 with ukranian regional settings. Today I test SeaMonkey 1.0.1 in english WinXP x64 Prof - same problem.
Seamonkey 1.0.x doesn't have the patch for bug 312287, but if you test the latest nightly build of Seamonkey, you'll find that it's been fixed there.


*** This bug has been marked as a duplicate of 312287 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.