The "Clear" button collapses when clicked.

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Woody Pope, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I have tried this on IE6 and it does not do this.

Reproducible: Always

Steps to Reproduce:
1.Click on CLEAR button.
2.
3.

Actual Results:  
none

Expected Results:  
same

CLEAR button should not have collapsed.

Comment 1

12 years ago
Actually, IE6 does exhibit the same behaviour, but with one slight difference; it puts the button's label back when the button loses focus (as a result of the 'defaultValue' property being populated on IE6, I'd imagine).

This is all the result of the element's onfocus method being set up to clear the element unless the element is of type 'submit'.  

Mozilla's handling is correct.  There is a bug in the user-supplied javascript.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Actually, IE6 does exhibit the same behaviour, but with one slight difference;
> it puts the button's label back when the button loses focus (as a result of the
> 'defaultValue' property being populated on IE6, I'd imagine).
> 
> This is all the result of the element's onfocus method being set up to clear
> the element unless the element is of type 'submit'.  
> 
> Mozilla's handling is correct.  There is a bug in the user-supplied javascript.
> 

Thanks to the tech staff, there was a bug in the Javascript allowing
this to occur. I fixed the Javscript and the problem is gone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.