it would be nice if users get notified if they are running buggy plugins

RESOLVED DUPLICATE of bug 271559

Status

()

enhancement
RESOLVED DUPLICATE of bug 271559
13 years ago
13 years ago

People

(Reporter: guninski, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

it would be nice if users get notified if they are running buggy plugins.

while it is difficult to keep track of all the warez plugins, i believe
that the majority of users who have plugins have java(tm), flash(tm) and
maybe some porn watching plugin.

so eventually someone keeps tracks of the known not buggy version of the
above plugins for the user's OS, some javascript (the js does *NOT* need
chrome privileges) compares the versions from navigator.plugins[i] and if the
user is running a buggy version he is given a message about the problem and
an url to install the new version.

this may be done from a web page and eventually from chrome.

there are worms in the wild targetting java(tm) applets and since the application is firefox, users may think it is firefox's fault.

imho technical non-savvy users don't check for new versions of
java(tm)/flash(tm).
Summary: flash(tm) and maybe some porn watching plugin. so eventually someone keeps tracks of the known not buggy version of the above plugins for the user's OS from a web page and eventually from chrome. there are worms in the wild targetting java(tm) and… → it would be nice if users get notified if they are running buggy plugins

*** This bug has been marked as a duplicate of 271559 ***
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
sample linux java plugin tester is available here - written in a hurry:
http://www.guninski.com/mozbugs/plug-test.html
You need to log in before you can comment on or make changes to this bug.