Corrupt downloads if file save dialog box is left open for a while (minutes)

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: stevem, Unassigned)

Tracking

1.8.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

File downloads can be corrupted if Downloads are set to ask for filename/path for downloads, and if the file save as box is left open for a period.  Files already being downloaded in the download manager and the current file are eventually saved when the dialog box is closed, but they are corrupt.  The period of time possibly depends on the size of the download, my experience has been that the time required is only a few minutes.  

Reproducible: Always

Steps to Reproduce:
1.configure firefox to ask for path/filename for downloads
2. Begin several downloads (Zip files are convenient as they tell you if corrupt)
3. Leave one download "file save as" dialog box open for a short while (perhaps 5-10 minutes after download would have completed
4. after a period, complete the file save as, all files that had not completed downloading will show done downloading, but will be corrupt

Actual Results:  
zip files corrupt, cannot be opened

Expected Results:  
valid zip files

Happens with a clean install of firefox, no extensions, and all recent versions of firefox,including 1.5.0.2

Flagged as critical as it causes corrupt files and loss of data

Comment 1

13 years ago
Download also corrupt when you pause them
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch
works for me with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a6pre) Gecko/20070626 Minefield/3.0a6pre ID:2007062604 + missing feedback

-> Closing as works for me
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.