VLC plugin crashes Firefox (win32)

RESOLVED DUPLICATE of bug 156493

Status

()

RESOLVED DUPLICATE of bug 156493
13 years ago
13 years ago

People

(Reporter: zephyrxero, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I will be filing a bug with the VLC guys about the crashing problems too, but the main issue for this bug report is that Firefox should not be crashing just because a plugin crashed.

The issue with VLC crashing seems to be related to quicktime .mov files, but still occurs somewhat randomly. Attempting to watch a trailer from the Apple site always crashes it (see example URL).

Upon crashing, VLC plugin pops up a window stating an illegal operation has occured. After clicking okay, Firefox crashes (in addition to the plugin of course).

Firefox gave me this message:

AppName: firefox.exe
AppVer: 1.8.20060.30804
ModName: ntdll.dll
ModVer: 5.1.2600.2180
Offset: 00011c29

I attempted to copy and the paste the debug info, but the crash tool wouldn't let me (perhaps another bug needs to be filed for that? or is it just a Windows issue?). It also created an attachment which I'll attach with this bug.

Reproducible: Sometimes



Expected Results:  
If a plugin or extension crashes, Firefox should give notice that a plugin or extension has crashed and place some sort of broken icon over the portion of the page that will not be able to work because of it. Firefox should continue to function, not crash just because a plugin crashed.

Comment 1

13 years ago
Easier said than done, BTW.

*** This bug has been marked as a duplicate of 156493 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
we already have exception handling for in process plugins.

could you please crash again and report a new incident id?

i'd like to know what stack we get that misses the exception handling we have...
You need to log in before you can comment on or make changes to this bug.